Fluid simulator – water too thick

Hi folks!
My first attempt at the fluid simulator proved harder than expected. I’m trying to create a fountain with water pouring down the edges of half-a-sphere and then fall down in a nice stream when it leaves the sphere. But instead the water is really thick and pours down in big lumps.

My blender version didn’t have any viscosity presets but they were set to base: 1 and exponent: 6 which I believe should be right for water? I even tried lifting exponent to 10 but it still comes in lumps. I baked with a resolution of 250, but this was the result:

Any ideas on how to resolve this? I want the water to pour down in a nice even stream. I’m not sure if what I want to do is possible but if it is I’d be grateful for any suggestion. Blend file attached.


Fountain-002.blend (708 KB)

You’ll need a wayyyy bigger resolution if you want small water drops or sheets. You also need to make sure that you’re using the correct scale for the world.

Thanks for the response. What resolution detail would you recommend? I tried boosting it up to 400 and blender baked it for about three hours but when it finished nothing had happened. The domain box was just a box all over the timeline. Any ideas what could be up with that? I also tried 350 but it seems as if the resolution is too high it won’t bake properly. The domain box is pretty big I guess, as you can see on my screenshot.

The scale seems to be set automatically according to the world unit which is set to meters, so I believe this part is right.

Hi alandor,

This may be off point but if you are trying to create a fountain effect I would think a fluid simulation is the wrong tool. Wouldn’t you be better off using the particle system?

Something like this: http://www.terracegraphics.com/blender/Fountain3.blend


  • The world scene scale has effect (try 8 and it becomes larger)
  • In your fluid domain there is also an option to set world scale.

But there is a nother thing that you might do, that is bake it all on a larger scale (for domain scaling dont drag but use S + x and type a number same for y and z) the reason domains work better on normalized numbers. Do this before you set it to act as a domain.
If you do it later, then remove cash files and re-asign it again the fluid domain role.
When you have baked it on a large scale then with the final bake result
You can go go to object properties (that small yellow cube in the tab menu) then overthere you can scale it down again.
This can be nice if you want much smaller water resolution, then the defaults of this tool.

oh wait there is another option that basically set the options for detail.
First there is the render quality called resolution
There is also at the bottom fluid particles you might set generate to 1 or more
And there is fluid boundery and under it subdevisions try seting it to 3 or so (not to high costs lots of computation)

i’d recommend you to see this http://cgcookie.com/blender/2011/05/17/intro-to-the-fluid-simulator-round-2/

just my 2 cents, but if your able to retrieve your bone settings by a script.
then wouldnt it be more easy to do some (auto) repeating calculation on the gathered data
to deal with displacement for as many steps you want.
Then when you have the data have another script to read your selfmade data.

if your good at working with such data, (and math) then well she could basicly walk straight or circles etc…

PS i dont say its easy, but since your deep into this, you know what data to look for what changes to find the delta changes, and to re-aply that to future frames.

Also on your objects that are standing still you might enable export particle mesh
this can look nicer