frame rate issue

I’ve recently bought a new graphics card GTS 250 1gb upgraded from 8500gt but now I seem to be capped at 60fps in BGE after changing to 120 in the world button… can someone shed some light.

(on the plus side I can now play crysis at max settings ;))

Why do you need more than 60?

why do I need more than 15fps…

The 60fps cap is intentional and is either put in place by Blender, your graphics card driver, or both. If you render every frame possible, you’ll get really odd results, so it’s best just to keep in sync with the verticle refresh rate. If you want to go over this 60fps cap (for benchmarking or whatever) go to Game -> Enable all frame. If this doesn’t do it, use the NVIDIA control panel to turn of vsync.