Freestyle with motion blur

I am trying to have motion when using Cycles and Freestyle rendering. I get this odd result. I have un-checked the motion blur option (instructions on the net advise so) and instead used vector blur (as in image)

You have to enable teh vector pass in cycle and plug the nodes in the apropiate way!

Hi, I’m trying to get this to work too and I can’t seem to get it right. I’m using Cycles. Attaching a screenshot of my compositor setup. This renders fine, there’s just no motion blur. I’m relatively new to blender. Blender file can be downloaded here.