From Obejct mode to Edit mode: go directly to vertex (or edge or face) edit mode key binding

Hi guys,
is there a way to assign a key to go directly from Object mode to vertex edit mode (or edge or face) with just one key?
For example I want to go from Object to vertex edit mode.
Now I have to press TAB (to enter in edit mode) and then press 1 for vertex.
I’d like to assign the 1 button to go directly from Object to vertex saving 1 key press. It seems not important but after a daily work, you saved many key press.

Do you know a way to do it?
I know that 1 (in Object mode) hides the first Collection but it’s not a problem, I can live without it or change the key binding.

Thanks in advance

Not without scripting.
Although you don’t need to script it from scratch, there already is a script that does that, something that’s part of a larger Pie Menu addon. Wazou’s Pie Menus.

He’s got it integrated as part of the TAB hotkey. It works for me what he’s got.

But if you still want the functionality that you described, then you can assign htokeys to the commands he calls in his Pie, as long as you have his addon installed!
For 1 you would use: mode.vertex
2: mode.edge
3: mode.face

If you don’t want to install his whole addon, you could grab just the file that has the Modes (, activate it and setup your hotkeys.

Just checked, the link to the thread I gave you is the old version of the script. For the latest one get it on his gumroad!

1 Like

Thank you for this suggestion.

I’ve downloaded the latest version and installed but I haven’t found in the Wazou pie menu the command to switch to edit mode (vertex for example). I’ve both tried to install just the (I haven’t found the file in the addon zip file) but I haven’t found the command to switch directly to vertex edit mode.
Am I missing something? Better ask to Wazou?

If you installed the addon, TAB is the hotkey you want to look at!

This is how it should look:

If that’s not what you see, then you either have conflicting hotkeys (check BlenderPreferences>Keymap>3D View> for that), or you didn’t install the addon properly.

I can’t understand what’s going wrong

This is the keymap option of the addon

These are my preferences for 3dview

About keybinding I’ve changed just the key to zoom to selected objects.

And this is what I see if I activate the Wazou Pie Menu with the ALT+RightClick as preferences.

This in Object mode

This in edit mode

I’ll check in the addon thread…I don’t want to bother you further.

Solved… I’ve downloaded the wrong addon. Sorry for this.

Now it works and it seems exactly what I’m looking for.
Thank you very much

I was just about to reply you got the Wazou RMB Pie, instead of just the Wazou Pie. Hey keep the RMB one as well, it’s got heaps of goodness :wink:

Can you send a screen how you set it up ? I like the addon but this pie menu for selecting mode is annoying. The other are wanderfull :smiley:

I’ve just enabled the “select modes” pie menu.
After a while I’m used to use like this.

But with your settings if i press TAB the pie menu appears and i just want to go to vert/edge/face directly from object mode by pressing 1/2/3 like it is in 3ds max.

these are my keymap settings

I don’t remember to have changed something else more

This makes no difference. The pie menu still pop up.

Sorry, I’ve previously misunderstood your request.
I can’t access directly to vertex/edge/face selection like 3dsmax and I have to use the dedicated pie menu but I’ve found that, without make some special setup, I can live with that pie menu. Now I’m quite used with it.

Hi guys,
I’m bumping my old request because I’ve a annoying issue.
I’ve found a good way to acces directly to edit mode in vertex/edge/face but I’ve a problem.
I’ve set the “2” key to go to edit mode as edge but it’s not working.
Obviously I’ve disabled the keybinding with “hide collection 2” but it’s still not working.
I’ve also tried to make a search with the keybinding of the key “2” and disabled all the action associated but with no luck.

How could I check what is conflicting that prevent my new key binding to work?
Just to be clear, the “1” and “3” keys are working correctly going directly to vertex and face edit mode.

Thanks in advance