Fullscreen switch in linux


After a long time reading this forum (about 2 years), my firts post. Here we go.

I’m having problems with blender in mi linux box. Each time I switch to another application (leave the fullscreen mode of blender) I get a segmentation fault. I guess this is because the video driver (xorg 6.8.1 with the latest r200 dri driver snapshot 9-11-2004), and not because blender but is really annoing.

So my question is if there is some way in linux to switch to not fullscreen mode in linux, and try if this fix the problem. I know the small icon at the right of the InfoWindow Header, but in my latest CVS self-compile in linux, it ain’t present.

Any idea.

PS: Excuse my probably really bad english.

I may be wrong, but there is no fullscreen mode for blender in linux. What you have is a borderless window maximized to the full size of your screen.

Of course, that doesn’t solve your problem. However, you might have some luck if you type “blender --help” in a term window. That will at least give you the command-line options.

I had a similar problem, my linux crashed when I used Blender in full screen without window border, but it works fine inside a window, to open blender in a window just type blender -w in a terminal.

Hope it helps,
Kha :smiley:

First, thanks for your replies.

Ok. Now it’s really strange. If I use the -w option, it crash inmediatly with a segmentation fault. If I use “-w -p 0 0 500 500”, in which the -p option tells blender to open in a 500x500 window it runs ok. But in the moment I try to resize it, and reach the right border of the screen it gives another segfault.

But finally I’ve found the solution. It was close the “gkrellm” (an app that monitor the computer state in linux). So simple. Now I can run blender fullscreen, windowed or whatever and it runs smoothly. I guess it’s something related with the state of the grekllm as a “Stay in top” window, but not 100% sure.

Well, I hope this could help someone in the same situation as me. And thaks again for your replies.