game engine crashes in blender 2.5x (but works in 2.49)

my blender 2.5 works completely fine, excluding the game engine. when I press P to start the game, blender crashes, opening a window “blender doesnt work anymore” (win Vista 32bit). the game engine works properly in 2.49, so I dont know what could be wrong with the game engine. Since I use blender mostly for games, I have to use blender 2.49, which is stable but I’d like to upgrade, though.
I’ve got a blender 2.5 training dvd which includes blender 2.52, and if I run it from the DVD I can start the game engine by pressing P, but when I install it it crashes. Modelling, texturing, rendering and so on just works fine!
I’ve seen that you can choose different options for installing, when I choose “Installation Directory” blender even crashes when I start it. When I choose “Application Data Directory” I have the problem discribed above (only the GE doesn’t work).
Would it make a difference if I chose “HOME-Variable”?

Note: I’ve seen that other blender users had the same or a similiar problem, so I cant be the only one. But I didnt find any useful solution for that issue.

Check the python version. On load up does the python screen say anything like “Unable to find python”? or “unable to load”?

no, it says: “found bundled python:…”

Hmm that is interesting, I haven’t had that happen. I have Python installed on the system, so it’s possible that may cause it instead of running a bundled pack.

in which directory does blender search for an installed python?

Mine is installed to C:\

thanks, so is mine, so that cant be the reason

2.52 is very old; try the 2.56 beta from, or wait for the 2.57 release, which should be coming out sometime next week.

I already tried 2.56, I have the same problem there. And I know that 2.52 is old, but I said this one was the only one which worked partially!

why hasn’t anyone asked what the game actually is?

what game?^^

That sounds like a strange message: “blender doesn’t work anymore”.

Does a cube, a light and a camera cause blender to crash when you tap the P key?

yes, its sth with the game engine, but I have python installed. my idea would be that blender searches for python in the wrong directory, although I installed python in the recommended directory. does blender 2.5x usually just crash when you dont have python installed/have it installed in the wrong directory? Is the game engine so much based on python? since the game engine works perfectly without any problems, I cant imagine what should be so different in the 2.5 game engine.

I admit to not being clear about whether it is necessary to have Python as downloaded from installed on my computer. Obviously I do, otherwise I’d be telling you that I don’t have it, but I don’t know whether I need it there to run blender.

But can you tell us:

  1. Did you see a message that said: blender doesn’t work anymore
  2. If I was to post you a blend that contained a camera, a cube, and a lamp, would blender crash when you pressed the P key?

I don’t think you have to have an installed Python, as Blender comes with the Python libraries necessary to run. Try deleting everything and then playing, or try executing Blender under a different compatibility mode (like Windows XP). Will that make it work? If so, then the problem might be with Windows Vista.

@ Equip: 1) Since I am german I don’t know what the window actually says in an english version of windows, but it is the standard indication window of win vista which comes up when a program crashes.
2) I dont think that will work, as I already testet to run it with the standard scene and with an empty scene.

@ SolarLune: What do you mean with another compatibility mode? I run blender as administrator. Is that what you mean?

No, I mean that you can right-click the Blender executable, and in Properties, there should be a compatibility tab where you can execute the program like it’s an older Windows OS. It probably won’t do a whole lot, but it might work.

doesn’t work either, but thanks anyway