Gamma issue Blender/Fusion


I am changing my workflow for a Blender and Fusion workflow.
For now I have my scene in Blender, with File Output nodes to export my renders as layered EXRs into Fusion. The issue I have is when I Read my renders from Fusion, they don’t seem to be linear, so they appear a lot darker than in Blender. Is there a way to export them from Blender with linear values ? Would the Gamma parameter in the Color Management tab be the way to go ?

Cheers !

Well don’t do that to start with. Just render multilayer exrs and use the composite node output. Better yet, don’t use composting nodes. File Output node is hacky garbage.

Fusion doesn’t apply any transform by default so a dark image likely means the image is linear.
You need to set your Fusion viewport to apply an sRGB transform.

The thing is that I have multiple view layers, I’m not sure I can export those just using the default exporter (as I am rendering an animation)

If I apply an sRGB transform on the viewport, if I use a node with a color parameter, the color I choose won’t be the same on the viewport, is there a way to fix that ? And same during the export, I guess the export will be dark as well ? Even if the viewport is correct

Makes no difference. View layers are just a prefix for layer names.

I would assume all ui color control are gamma corrected and internally use linear values, but it’s never been an issue so I’ve never considered it.

You need to read up on linear workflow and specifically linear workflow in Fusion rather than assume something needs to be ‘fixed’.

1 Like