Glass casts opaque shadow - Help

I have assigned a transparent test-material to a cube and placed it over a flat plane. When I render it the shadow is solid black, although the cube renders transparent.

My uneducated guess is that it’s a hardware issue (older Mac mini). Using Blender 2.58. Can anyone help?

You need to enable transparent shadow on the object receiving the shadow.