glass material

I copied the materials formula for glass I found here

but it turned out opaque (turned on raytracing). Do you know what’ s wrong?

In Mirror Transparency, turn on the ZTransp button and move the fresnel slider up a bit … adjust to taste :slight_smile:

Render and notice that you can now see through the cube.

Hope this helped.

Edit: By the way, you don’t have to have raytracing turned on. The internal renderer can render your glass transparant.

Got that working now. Is there any way I can save material settings to reuse? The ‘F’ button for saving the datablock doesn’t bring up any dialog so I guess that’s something else.

The F-Button saves the datablock even if there is no real user of that datablock (F for fake-user)

you can import your material from another blendfile with Shift-F1 as you can import any other object
if you save all your materials in one special blend-file you have a material-library like


No time to read all posts but after downloading the .blend file I saw that ray-transp and ray-mirror were off. They need to be on.

No, they don’t. You really should read the above posts.