I’m trying to create a glass plate (like window glass).

I played around with the settings and managed to make the sphere in the menu look pretty much like glass.

After rendering the objects below my glass object appear very dark and my glass itself looks like it’s sort of greyish (like grey-colored glass.

I noticed turning the energy from a hemi light up, makes it clearer, but hemi light doesn’t cast really nice shadows…

So first of all: which would be “glass settings”, and how do I set my lights (and which lights) to make it actually look like glass (preferably with a small reflection)

Well if you’re in cycles and want clear glass you need to change the colour of it to completely white, by default it’s set to just off white.
Also your objects could be dark because currently cycles won’t cast transmission shadows through glass. I actually happened to do a video today on how to cheat caustic in Cycles if it’s at all useful :slight_smile:

Easy fix!! I had this problem when I was making water. Any object that is appearing dark through the glass must have “receive transparent” turned on in the shadow panel of that object’s material pane. I’m not sure, but I think this requires raytracing to be turned on in the render panel, and for the glass material to cast raytrace shadows. You might also try turning shadows off for the glass material, but you might lose some realism. (I don’t use cycles yet since my characters all have hair, so I can’t say much if you’re using the new renderer)

Enigma: eh… cycles? I’m new to Blender… not sure what cycles are. I set it too 100% white. I’ll have a look at your video

GreyWanderer: I have “receive transparent” on and shadows for the glass part off. It’s sligtly better, but still not clear.

And I stil don’t manage to have it reflect a bit of the light on the scene. I might have to replace my lights for that…

Sorry, wasn’t sure if you were talking about Blender Render(Blender’s internal engine) or Cycles rendering engines. They’re basically alternative methods of rendering images in Blender, the newest being Cycles which gives more realistic results but at times can take more fiddling with to get what you want without a massive long render time. You can change between them at the drop down menu at the top.

Just play around with them if you haven’t had a chance to :slight_smile:

I tried cycles render now, but that somehow creates an image with a lot of noise…probably has to do something with the render settings I suppose… but no clue

Cycles renders in, well… cycles. Instead of rendering at full resolution in squares, it renders the entire thing(usually noisy/pixelated looking), then gets more clear with every pass. You should get a clear render if you let it sit for some time.

Mh… It doesn’t seem to do anything. It renders once, and then stops. The bar indicating the render-progress also disappears… like he’s finished rendering…

Something with the settings? I noticed under “Performance” I can check “Progressive refine”. Now it does seem to render several times. Refining the images each time… but it’s still noisy

It also turns my “glass” on top of the box completely untransparent.