Glowing glass!

Hi guys! I am a novice user Blender. I really need help in creating such a material!

In reality, it is a glass tube filled with gas that glows if electricity is supplied to it. Help create material that would display this glow inside the tube. Or at least hint in which direction to move?

this might be related

Thank you, but this is not exactly what I need. I need a shine like in the picture, it is not even and not bright, but well visible, I do not know how to achieve this effect. :frowning: Here is a video of how it works live.

Model the glass tube, then model a separate ‘gas’ object that sits inside.

Apply a suitable glass material to the tube and a volumetric emission shader to the gas object. Just make sure the glass object and gas object dont overlap - gives funky results.


You can even animate the gas like in your video using volumetric procedural textures etc.


thank you very much! This is a great thought! But
I had a friend problem. Render is very different from the render on the preview. What am I doing wrong?

I’m officially curious - what the hell is that thing and what is it good for anyway?

this is darsonval, a device for skin and hair care … it seems … this thing beats you with small lightning bolts, and it seems to be useful. :slight_smile: these are sold on amazon. I need to render this thing: (on a white background. but I can’t do it :frowning: help :slight_smile:

No idea - it works fine for me. Are you using cycles?

Perhaps post the blend file.

yes, i use cycles. maybe problem in v 2.80
test.blend (1.1 MB)

<< Wasn’t a bug, see other post >>

Interesting, I have the same render bug with your file using the last build (blender-2.80-3b8ae2c08f5c)
But it render correctly with blender-2.80-989d8543853c…

You didn’t pack your hdri too, had to replace it.
With the last version, i cannot see the hdri background in Rendered view with cycle or eevee.

With the last version, you have to uncheck Transparent glass in the film tab for it to render correctly.

Transparent glass is on when you open your file with the last blender, and it is off when you open it with an old version. Weird.

eally. If I uncheck this box, it becomes much better! Thank. Can you show what your render looks like?

Note that it is with a different hdri since you didn’t pack yours and
It is with the Transparent glass option disabled:

Made. Thanks to your advice, in two layers, outside the glass, inside the plasma. Plasma is such a material. The effect of the selected area of the shader is not always visible, only sometimes at an angle. They can be neglected. Thanks again