Glowing Light Source

Hey everyone,

I’m currently working on a lightbulb. Does not sound so spectecular but I ran into something that I’m wondering about:

How do I make the wire “glow” correctly? And I don’t mean the bloom or glare fx on top of the render. I mean the actual wire.

It does not make a difference how high I set the emission value of the wire material emission shader. It still stays the same color. I would expect that I gets more and more to white like in real photography.

I’m using the blackbody node for the tungsten color of 1500.

What am I missing here?

This one is my render:

This one is the reference:

I would try adding more power to the emission. But also a glare node limited to the brightest parts, possibly a secondary glare (or soft glow) to the final.

Did that. Didn’t change anything.

So what you say is, that it’s practically is not possible to get this in camera but has to be done after rendering in compositing?

Do you have clamping enabled?

Correct. Sorta, kinda. You could scratch up the glass surface a little bit, and you could do some volumetric stuff in the glass and/or volumetric string. But I don’t think I would bother. At least not as a first attempt.

1 Like

Are you using “Standard” view transform or “Filmic”?
Only the latter will fade into white the brighter the tungsten is. Standard will just stay yellowish.
So make sure you use Filmic.

This is the same render of a text with emission strength going from 0 on the left to 100 on the right. The only difference is the setting in the color management. First with view transform set to “Standard”:

And then with “Filmic”:

Make sure you don’t have direct illumination clamping enabled in the render panel.

Incidentally on the subject of bulb filaments - I made a node group just for this purpose. All you do in input the temperature of your filament - and it calculates the correct colour temperature and emission brightness based on Planck’s law:

It’s available on blendswap if you want to download it.

I retested that, because I already was on filmic mode. Found out what the real issue was:

Good advice! Actually the Indirect Lights were clamped down to 1, so the gloas cover of the bulb hindered the rays to get through, resulting in the color not changing. Once I upped it back to 10 and direct clamping to 0 it works.

Thanks guys! Will post an image of the final result soon

Final Result:

1 Like

Well done!
I have a similar query - making an afterburner flame - see pic. Firstly, where can I find the illumination clamping settings? I’m getting the emission, but no glow. Secondly, is there any way of getting alpha into the color ramp, so that the flame fades to alpha instead of black?

My bad - left out the pic :blush:

In the shader editor transparency is its own shader, and has to be worked with the same way you work with the other types of shaders. After you set the black in your color ramp to be transparent feed the alpha output of the color ramp into the “fac” input of a mix shader, and blend a transparent bsdf (top slot) with an emission shader (bottom slot):

example.blend (448.2 KB)

Thanks so much, Zanzio. There it was staring me in the face - but I guess that is how we learn.


This is an interesting case too! Thanks for sharing this.

Also I was fiddling around with fog volume to emulate glow in camera. But that doesn’t make any sense in terms of render times and it doesn’t look as good as the results in the compositor.

Is there any way to get glow and glare on camera?