GLSL Shadows and Camera script


I have a little problem with a simple script that I made to move the camera in a top view. Everything works fine except because of the selected light.
In the attached file, if I active shadows in the sun light, the script doesn’t work, but if I keep it unselected, it works.

I really don’t understand, because the script isn’t light related at all…

Any clue??


camara_top_2.blend (572 KB)

I’ve enabled buffer shadows and it works just the same. I’m using Blender 2.65a.

Ok, it’s a matter of the resolution of the buffer shadow…and my pc I guess. With lower values it works.


And it’s a problem of the resolution of the player too. With lower values for buffer shadows and bigger for the player, it doesn¡t work neither…