Google Maps Models Importer

Mmh this is surprising, the rdc is fine except all textures are black. Was google maps all black whiel capturing? Which hardware do you have (GPU)?

Hi! I’m getting this error:
The export with RenderDoc 1.6 went well, I’m on Blender 2.82 clean installation. The add-on installation also seem ok.

I’m trying with different files .rdc
Some I’ve exported myself and some from this post as well.

Hope someone can give a hand! Thanks!

Traceback (most recent call last):
File “C:\Users\nicoc\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\MapsModelsImporter\operators.py”, line 53, in execute
importCapture(context, self.filepath, self.max_blocks, pref)
File “C:\Users\nicoc\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\MapsModelsImporter\google_maps.py”, line 210, in importCapture
filesToBlender(context, prefix, max_blocks)
File “C:\Users\nicoc\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\MapsModelsImporter\google_maps.py”, line 170, in filesToBlender
indices, positions, uvs, img, constants = loadData(prefix, drawcallId)
File “C:\Users\nicoc\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\MapsModelsImporter\google_maps.py”, line 142, in loadData
img = bpy.data.images.load("{}{:05d}-texture.png".format(prefix, drawcallId))
RuntimeError: Error: Cannot read ‘C:\Users\nicoc\Downloads\17\17-88083tt\17-00000-texture.png’: No such file or directory

location: :-1

1 Like

Please share the .rdc file when reporting importation trouble…

This is a very nice add-on
But Inject is not displayed in the upper left of Chrome
RenderDoc also doesn’t seem to work properly
Nvidia GeForce GTX 1060

@InamuraJIN I cannot tell without further info. Maybe you could record your screen while trying to inject? Did you use the correct shortcut for starting chrome? Did you ensure chrome was completely stopped before starting the process?

Google Map’s 3D view mode is not supported anymore for some region. (I don’t know why, and I don’t know this is temporary or not)
This is one reason why 3D button is not visible on Google Maps for some people.
The solution is, change your region to United State.
You can find the region at the bottom-right on your Google Maps.region

Then you will find 3D and rotate button on your Google Map.

Before this, I have tried the followings.

  • appending ?force=webgl at the end of google map URL
  • enable Globe mode in satellite mode
  • refresh Chrome hardware acceleration (turn on -> turn off -> turn on)

Nothing helped. But the solution was simple.:slight_smile:
It seems to be the same in most other regions.
I think it would be nice to show this information in the Github FAQ.

Thanks a lot for suggesting this, I was not aware of it! I added it to the FAQ :wink:

Hey man 2 days ago anything goes smooth, imported and worked, now i get the unknown location -1 error on every rdc i try to import. Same process same program and same unknown location error ! I even took the 2.82 a and deleted the older versions, and still nothing !

1 Like

Please provide rdc file so that I can help, I cannot just guess.

Ok dude figured out this right now, seems there is a BIG difference between google earh, and google maps. I was importing from google earth today this is why it was not working ! Guess this is what happens when im tired ! Anyways thanks a lot for this addon man, it’s grate and usefull a lot, is why i panic when i got that error, cause is very usefull. :joy_cat:!

Ok! With the last version it should display a proper error message that suggest that this might be the error (many people try to import from Google Earth, I may adapt the script to it but not done yet).

Man is there a way to synchronize the imported models with the gis coordinates inside blender? Like when importing the model it would be on the right spot on the gis map ?

Unfortunately not yet, see https://github.com/eliemichel/MapsModelsImporter/issues/40

Thank you!
When Inject is not done, the screen cannot be recorded.
Added “–gpu-startup-dialog” to shortcut
Chrome has confirmed that it has completely stopped

I read this site
https://ken26u.hatenablog.jp/entry/2020/02/13/204324
“Inject” succeeded when using Chrome portable
I was able to record the screen, but when I opened the data, it was full of noise


When I open it in Blender I get this error message

I’ve tried everything but haven’t solved it yet

“Enable Globe mode in satellite mode”
I did not understand this

This blogpost you link seems a bit outdated (from what I can understand without speaking Japanese ^^), di you ensure that the shortcut link is:

C:\Windows\System32\cmd.exe /c "SET RENDERDOC_HOOK_EGL=0 && START "" ^"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe^" --disable-gpu-sandbox --gpu-startup-dialog"

Hello! Everything before importing the .rdc in blender seemed to go smoothly but when importing I got this error:

I tried on two different locations.

Can you please:

  • check that C:\Program Files\Blender Foundation\Blender 2.82\blender-2.82.0-git.016464db980f\2.82\python\bin contains a file python.exe;
  • profide at least one of the .rdc files;
  • check that this is the full log (and if possible copy it as text – using right-click > copy, cause Ctrl+C does not work for this)
1 Like

@Mink

–disable-gpu-sandbox --gpu-startup-dialog

After trying this, I can no longer inject

It looks like I was able to record successfully by installing it, not the Zip version
But I tried Importing with Blender 2.80 & 2.81, but I got an error
Uploaded error console and RDC file
https://drive.google.com/open?id=147-FxqyMl6uYZeC_AajXVsuczNECuDsF

@InamuraJIN I have the same error, although the capture opens well in RenderDoc, this is surprising. Which version of RenderDoc did you use to capture it? Try with v1.6 if it is not what you already did.