GPU - Cycles render problem

Hello!

Have some problem.
Open any scene, choose cycles, render with CPU - all ok.
Open any scene, choose cycles, render with GPU - have a render full of World light (just monochrome picture, m.b. with noise if samples is low).

Blender 2.77 and 2.76.
GPU - ASUS Radeon R9 280X-DC2T-3GD5 3GB GDDR5



Try again with latest builds: https://builder.blender.org/download/
There might be improvements on amd-gpu-cycles area.

Sometimes it works, sometime is not.

GPU-CPU-test.blend (1.83 MB) - in this file GPU dont work right
Tiny house.blend (783 KB) - in this file GPU work right
Help, please)

AMD confirmed the issue. Even with latest Blender build, drivers have OpenCl bug. Fix is on the way.
Read this whole thread:
https://community.amd.com/thread/200513

Oh, i found solution in this thread: using “progressive refine” option in performance menu solve the problem!
Thank you very much!

Yes, only it renders slower.

Yes, but faster, than CPU :slight_smile:
Also the problem is SSS dont render with GPU. Is it depend on videocard?

Not yet implemented on OpenCl with AMD GPU.
https://www.blender.org/manual/render/cycles/features.html

I get this now when I render with GPU it is like the lighting is gone…