GPU for my viewport performance

I have a Ryzen 7 1800X with 32 Gigs of ram that use for rendering. Allows me to render big scenes, in decent amounts of time. My 1050 Ti, seems to be a bottle neck when it comes to working on my scenes: The viewport can becomes slow, even unresponsive at times. My question is, what would a better GPU do for me? Like many, I’m eagerly awaiting for NAVI to come out.

Like some others I am happy with my 2070.

Hi.
Where are you having problems? 2.79? 2.8?
Be careful, some tasks in viewport depend on CPU and others on GPU. That you render fast in CPU with Cycles does not guarantee that the CPU is good in other aspects that depend mainly on single thread performance.

Are problems in Edit/Sculpt mode?. The best way to test it is that you with a program to monitor CPU/GPU usage you open a scene of which you have performance problems, and you see at the same time on monitor if CPU or GPU is the most used.
It would be good if you give us more information about where you are having these performance problems, to determine if it is really a GPU problem.

Can you share a .blend that you find to be “slow and unresponsive”? It’s possible that a faster video card (or simply one with more memory) might make a noticeable difference, but it’s also possible that you’re doing something that will be slow on the most expensive video card that currently exists using the current latest version of Blender.

the blend file is 50 megs. But this should give you a notion:

the modifiers are disabled on the viewport, yet, If I move my mouse, the windows task manager shows GPU use at a high percentage, like 99%. Turning on the modifiers on the viewport, actually makes blender unresponsive for a few seconds, maybe even a half a minute.

Well, on the one hand, I would mention that your video card alone has 87,000 times the memory of the entire computer I first tried to do 3D on, and one of the oldest jokes in the world is “Doctor, doctor, It hurts when I do this!” “Then, don’t do that!”.

There are lots of knobs you can turn in the world of 3D, and most of them will result in unacceptably bad performance if you turn them up high enough, so once you get beyond relatively trivial scenes then you have to start actually paying attention to technical details like how many polygons, and what type of modifiers you have to evaluate.

There may be programs that are better than Blender at this specific level of detail, but if you turn the knobs up a bit higher you’ll probably be able to overload anything that exists today. This is a case where an Nvidia 2080 Ti would certainly get you better performance, but it might not be that much better.

My advice (which may not actually be worth much so no worries if you don’t like it) is to look into ways to simplify the scene and set it up using the most efficient strategies for the version of Blender that you’re using, before worrying too much that your hardware is insufficient.

It’s always great to use the best hardware you can afford, but keep in mind that people have been trying to achieve similar things since computers first were a thing and the trick is often how to make do with what you have, when what you have can never be everything you can imagine.

I find it interesting that when scenes get big enough, turning a modifier’s viewport on or off causes blender to stop responding for quite a bit of time. And from the windows resource manager, this is a single thread function. Then again, windows is not very good at seeing what the video card is doing.

If this is Blender 2.79, the most likely is low performance comes from CPU single thread performance, and Blender own limitations that sometimes makes interface heavy regardless of whether you have the best hardware in the universe.
In general AMD has worse single thread performance with intel equivalent price range CPUs:
https://www.cpubenchmark.net/singleThread.html

In addition for many tasks that in theory are multiple thread in Blender, I have noticed that single thread performance also makes a difference, as in this particles simulation Benchmark (results below in comments):

Anyway, your CPU is not bad and you should do what @Zoot has told you about learning about how to optimize your scene for fast viewport performance, taking care in the order of the modifiers in the stack, configuring properly modifiers with adequate values for viewport. If you use particles system, you can also configure some things separately for viewport to make it lighter. Do not forget to investigate about Simplify options in Scene tab, where you can configure some things globally for viewport.

By the way, I think that in Windows people use GPU-Z to monitor GPU.

1 Like

If it’s Subdivision Surface modifiers that are giving you trouble, then try checking the OpenSubdiv box after going into User Preferences -> System and setting the OpenSubdiv Compute in the lower left corner (try both GLSL Compute and OpenMP and see how they affect the performance). This is for 2.79.

You might also try loading your scene in the 2.80 beta and see how it performs there.

1 Like

My main model has 151 160 vertices and has 2 modifiers:

bevel: 2 segments
subsurf: also 2 levels

I don’t have adaptive on it but I do have it on the ground mesh, so experimental mode is on.

I am having issues here with particles. It does not use my gpu… Idk if particles dont use GPU or if the entire viewport does not use it…

Particle editing is lagging and GPU is not being used for it.
GPU is in 0 %

I was trying to move the particle… but it was lagging a lot.

1 Like