GPU rendering works but only after I open the system menu

This is a minor issue, but I’m completely flummoxed.
Here’s a quick step by step.
My GPU option is greyed out upon opening Blender.
I open User preferences>System. My GPU box is already checked under the CUDA section.
I close the User Preferences window.
Suddenly GPU is no longer greyed out and works perfectly.

I tried on both 2.79 and 2.78. Same thing.

I tried running Blender from the terminal and get no error message.

This is with Manjaro Linux, Threadripper 1950x, GTX1070

Anyone with a similar issue or ideas to clear up the mystery?

It isn’t a problem I have experienced, but something to try is:-

File - Load Factory Settings

CTRL+U to save as default

Enable GPU rendering

CTRL+U again to save as default

Thanks. I tried it but no luck. Same thing on windows. Maybe it’s a hardware issue.

Do any of your user preference changes get saved? Addons, etc.?

Find your configuration — on linux this is probably under ~/.config/blender/2.79/config/ — and take a look at the date of your user preferences before then after making and saving a change. A log of this on my machine,

[email protected]:~$ ls -l ~/.config/blender/2.79/config
total 676
-rw-r--r-- 1 glenl glenl    420 Feb 13 16:34 bookmarks.txt
-rw-r--r-- 1 glenl glenl    505 Feb 13 16:34 recent-files.txt
drwxr-xr-x 2 glenl glenl   4096 Feb 13 10:01 sculpt
-rw-r--r-- 1 glenl glenl 552824 Jan 28 16:50 startup.blend
-rw-r--r-- 1 glenl glenl 126420 Feb 13 10:01 userpref.blend
[email protected]:~$ # start blender, make a preference change, 'Save User Settings'
[email protected]:~$ ls -l ~/.config/blender/2.79/config
total 676
-rw-r--r-- 1 glenl glenl    420 Feb 13 16:34 bookmarks.txt
-rw-r--r-- 1 glenl glenl    505 Feb 13 16:34 recent-files.txt
drwxr-xr-x 2 glenl glenl   4096 Feb 13 10:01 sculpt
-rw-r--r-- 1 glenl glenl 552824 Jan 28 16:50 startup.blend
-rw-r--r-- 1 glenl glenl 126420 Feb 15 09:48 userpref.blend
[email protected]:~$

Hi.
This is weird considering that the same thing happens in Windows and Linux. Is it a new PC/machine?
Just in case from the motherboard BIOS configuration, you make sure to have PCI-e (discrete card) selected as the primary graphic display and you disable Multiple GPU option (or multimonitor for example, or something similar).

Edit:
I just realize that you have AMD cpu. Your motherboard has no onboard GPU, right? I’m not even sure that those options that I had told you before are in your BIOS.

@Alec1, I just reread your original post. Are you saying that all you do is open up preferences, CUDA is already set, your GPU is already checked, and all you do is exit without saving? And then it works?

@YAFU, OP says this is only happening on Manjaro Linux, right? All I know about Manjaro is that it is ArchLinux based.

Yes, CUDA is already selected. To be metaphorical,it’s as though Blender just needs to be reminded.
This is a new motherboard/chip (old graphics card). But, as your (Yafu’s) edit suggests, I’m not seeing anything relevant in the bios.

I’m baffled. Since you have the same issue on both windows and linux (finally noticed that detail, @YAFU) it is probably not a driver problem. You might try the card in a different PCI slot but that’s basically a shot in the dark.

Thanks for your help with this @g60 and @yafu.
I ran some benchmarks, and GPU rendering performance doesn’t seem to be suffering.
So, for now, I’ve saved my startup file to just open up to the User Preferences, so that GPU rendering will be recognized.
I remain baffled as well.
If you’re reading this and have a similar problem. Please let me know if for no other reason than to assure me I’m not going crazy!