Grainy AO & Shadows?

I did the research on Google and here, but did not find adequate information on reducing the grain in my AO and Shadow. I tried using Sun light sources and Area lights, changing Samples, not sure of what to adjust, not sure of what I have changed since prior successful renders. Any help will be appreciated. I am using Blender 2.92 currently, Cycles, Optix, with DeNoising turned on?? This render shows both for reference.


It’s not normal such noise in a well illuminated scene. How many samples did you use to render?

If you prefer not to share your scene, could you delete all the content of the scene and save a copy of the empty file to analise? Maybe looking at your settings we can find a clue.

I would not have thought to dump all of the objects/images as the actual file is 1.2GB, unwieldy to be sending anywhere, thank you for the idea. I kept the lights, so hopefully there is enough to problem solve. I am also including a screen shot of what I presume would be useful?? But what do I know?? apparently not as much as I need. Thank you.
House&Yard-Scene_reduced-file.7z (2.8 MB)

You have marked the post as solved. Did you find the origin of your problem?

I did not Check [Solution] and don’t understand why it has been placed. I had thought that you, the sender, had checked it, so I am still without a resolve. If you have any ideas, thank you.

I will look at your file now

What king of environment are you using, cause I believe there are some addons you use that i don’t have.

I use a variety of Addons, but I do not know what might be related to environment??
Where might you be looking, perhaps I can answer??

There’s something corrupted on your file. You can change the amount of samples but the render is not accepting the number you put.

For this amount you put your render never should run so fast as it is running in my graphic card. You had 1024 and it was rendering as fast as when I put 12 samples. The same when i put 2000 samples. Same speed and same noise level.

Also I realized that you set 1024 max bounces with 16 diffuse? This is crazy.

Well, I suggest you create a new file and append all your collections directly to this new file and set it up again.

Something is wrong with the file and it’s not in the settings, even you putting strange values for your bounces, that I suggest to correct. Didn’t you realize that the render was too fast?

Thank you for your ‘looking around.’ I have little experience with ‘corrupted’ files, but had to correct one recently and took your suggestion, opened a new file and appended all of the elements of the suspect file, reset most of the setting to Default Values and rendered again. I had put in the ‘weird’ values since suggestions were directed towards increasing Samples as a means of reducing Noise. I had not had this problem before.
I am pleased to say that I think the corruption has been purged, but I will want to investigate this issue as I no not how it would have happened, but I will want to avoid such difficulties in the future. Thank you again for prompting my choices.
I think it is solved now, but I will be watching.

1 Like

The weird values were the bounces and not the samples. No one uses 1024 bounces. I use 2 diffuse bounces in interior scenes. You have much more than you need and the only thing they are doing is to slow your renders.

Also I don’t think you need 1000 samples for a scene like that. It’s an exterior scene and it normally doesn’t need so many. Your problem was not in the samples amount. Maximum bounces at 12 is more than ok.

Samples you use when they are needed. If you make your scene with 200 samples and the noise is ok, then you render with 200 samples. They tried to help, but they did not know that your file was corrupted.

I had a look at your file, there is a setting in render properties under the sampling advanced tab called layer samples. You had it set to “use” and this was culling the samples as Calandro noted. I set it to “ignore” and the render processed all the samples giving a clean result for all layers (combined, AO, shadows etc)

Nice that you saw that. I would never find it because since I use the basic Blender build I would never think that existed. From where this setting comes from?

You can set sample settings per render layer which will override the general settings. This setting only shows up if you have set different settings for some view layer. There is a setting in the view layer tab under override that overrides the samples for the active view layer.
Possibly the op set them by mistake. It is not something I have used but I thought that it was strange that the file rendered so quickly having loads of samples.

Ah, ok, from the material override. I never used that also. I know it could handy in many situations, but never did. Now I understand. Never knew that override materials could also override the sample settings of you render settings tab.

I knew something was overriding the samples amount, but I would never get there. Now I know it. :wink:

Yes, this way he could put 1000000000 samples and would not have any effect.

They are separate override options, one for is for the materials and the other for render samples. You can use them independently. Maybe in the future there will be more options to override.