Graphicall builds on Linux: How do I get them to run?

I’d like to have a recent 2.5 build on my Ubuntu linux machine (10.04). Graphicall lets me download a build, and I downloaded several already, but for the life of me I can’t figure out what to do with them. The build comes in a tar.gz archive and inside there’s a “blender25” folder. In it there are more folders, one binary (“blender”), licenses and a readme file. The readme file says I should extract the contents of the archive, take the .blender folder and put it in my home folder, and run blender. I found the .blender folder and did as I was told but double clicking the “blender” binary didn’t do anything. I checked and it does have permissions to execute.
Is there anything I’m missing? I’m not a Linux expert so perhaps I’m missing some fundamental aspect of running things on Linux without installing them through the package manager. should I extract the rest of the archive’s contents to some specific place? run something as root? install some packages?

Hi Michael_GR.
I am using Ubuntu 10.04 too, so here is what to do:

  1. Right click on the desktop and select “Create Launcher…”
  2. At the new window you will find some fields you must fill. For the Type: select “Application in Terminal”. For the Name: write something like “Blender 2.50”. For the Command: this is the important one. You must Browse to the folder you have untar the file you’ve downloaded from Graphicall and choose the blender executable. It should look something like this: “/Your/Path/ToBlenderFolder/blender”. For the Comment: Write a helpful description or leave blank.
  3. Click the newly created Launcher and Enjoy :cool:.

One last thing. On Linux world a program must have all the dependencies it needs to run installed in your system. You can see what is missing at the terminal that will open along with the blender window (Remember step 2 in the creation of the Launcher?) I found that the builds Fish is making are the easiest to run from user perspective. Try his first.

Four simple steps:
#1. untar/unzip file in a dir
#2. enter that dir in the command line type:
ldd blender | grep not
If it returns nothing you’re good to go. If not, you must install the missing dependencies (apt-get install …).
#3. make sure that the blender file in the root folder is executable e.g. rwxr-xr-x; if not change its properties with chmod
#4. run blender by either clicking/double clicking the executable blender file (from a gui such as kde or gnome) or from the command line by typing:

One simple step, get a build from Fish. Extract it, double click the Blender icon. They always work for me straight out of the box.

no need for any command line:

in the file explorer, go to the folder you downloaded the file to, select it and Edit -> Extract here. Then enter the folder it created and double click on the blender executable.

if you manually copy only the executable to some other place, it won’t find some libs or folders that came with it in the zip…

I remember those days and fun with trying to do something simple under Linux. Thank you god for Win user friendly GUI.

@Zanos, I wouldn’t go that far, I tried to do a Blender demo once, but unfortunately it had to be done on Windows- I’m a mac/linux guy. I went with 3 different builds and none worked right. Pretty much sucked.

@Jay: please note that the fact that sth works on your system out of the box does not mean that other users will meet the same fate. As linux is not windoze, it really depends on the system/distro/config.

@namekusejin: if you unzip the tarball and it fails to load on linux then you gotta go to the command line. How else are you gonna check for missing dependencies?

@zanos: you don’t really know what you’ve been missing. For one thing, your M$ windoze box has been using you rather than the other way around.

You know even when you’ve got it untarred and all that, it probably still won’t run due to library naming differences between different Linux distro’s.

Building blender on Linux is incredibly easy once you’ve installed the development files it requires, use scons and no problems.

Give it a go maybe.

Yep, my guess is you’re missing a library which is why it won’t run when you double click it.

Nice to see Zanos back trolling the linux posts again, we missed your totally and completely unhelpful input…

I use Ubuntu 10.04 64 bit.
I build Blender 2.5 on it and post my builds at graphicall.
People that have had troubles running it have done two things to help them.

  1. People have reported that installing blender 2.49 from the Synaptic Package Manager helped to get 2.5 working.

  2. You need to install the libraries that Blender 2.5 needs to run.
    I would just install all the libraries that are needed to build Blender as they are sufficient to run it.

If you want to install all the libraries, just open up a terminal window and paste the following code into it:

sudo apt-get install gettext \
 libxi-dev libsndfile1-dev \
 libpng12-dev libfftw3-dev \
 libopenexr-dev libopenjpeg-dev \
 libopenal-dev libalut-dev libvorbis-dev \
 libglu1-mesa-dev libsdl-dev libfreetype6-dev \
 libtiff4-dev libsamplerate0-dev libavdevice-dev \
 libavformat-dev libavutil-dev libavcodec-dev libjack-dev \
 libswscale-dev libx264-dev libmp3lame-dev python3.1-dev

If you already have any of the above installed, then it will skip them instead of re-downloading and re-installing them.

The libraries are listed on this page:

i had the same issue - just unpacking and starting it doesn’t work.

I went inside the terminal to the Blender folder and tried starting it which
then of course showed that it was not installed.

with “sudo ap-get install blender” it looked for missing dependencies and installed those.

But then Blender still does not start.

I had no luck with any builds using Ubuntu until I used a build from Fish- I don’t know what voodoo he is using, but they work. He is building in Ubuntu and testing on several versions, so I guess that helps :slight_smile: Hence my recommendation to the OP, the mia OP, who is using Ubuntu as well.

I got it to install but when started it it was the 2.49 interface …
but from graphic all I downloaded the 2.5 build.

during the process of installing dependencies this must have been mixed up.

If dependencies are not broken and B2.49 is installed and B2.5 is extracted to some folder in your home folder, instead of clicking on blender binary file just rename it to blender25 run terminal in B2.5 folder and do “./blender25”.
It works on Karmic and indeed Fish’s builds are the best 'cause I don’t need Python3 to be installed.

Thanks everyone I tried a build by Fish and it worked.

Fish is the man! He builds a good variety of branches as well, which is nice.

Thank you, that is exactly what I needed for it to run.