Grease Pencil rig works in viewport but not render?

Hi folks!
I have a grease pencil rig and I am using a bone to drive the time offset modifier of the GP mouth layer. Everything works exactly as I would like it to in the viewport - however, when I render, the GP mouth layers are all out of place and completely wrong!
All modifiers are set ‘on’ for viewport and render.
Any ideas on why this is?
Viewport - mouths are correct:

Render - all wacky (I know the lighting is dark - just ignore that for now! Also the yellow cat’s mouth looks correct, but if I move the bone driving the time offset at all, she also goes wonky) :

GP Layers are parented to the bones within the GP object. Each character has 4 mouth layers with their visibility being controlled by a custom property on their “dialogue” bone.

Right now I am planning on rendering out animations using viewport rendering as a workaround, but would definitely like to render normally…

Here is a Dropbox link with a blend file.
Blender v2.92

Thanks everyone! Any help is greatly appreciated!

1 Like

Hey everyone! It’s been solved!

Turns out it was just a weird bug in Blender 2.92. I opened the exact same file in 2.91.2 and everything worked exactly as expected!

Not sure what happened in 2.92, but hopefully it will be fixed next release!
Thanks guys!