Grease Pencil undo performance

I’m trying out some grease pencil drawing with a tablet, which means I spend a lot of time hitting undo. But each undo takes ~4-5 seconds, which is far too long to have drawing be viable. My scene is not particularly complex: 130k verts, no subsurfs on, no other performance issues. No lag when posing with my character rig. Undo occurs instantly in edit mode on mesh, but is slow on grease pencil in both edit and draw modes. It is also generally slow in object mode. And it was instant in pretty much every way on this same character back in 2.79.

Is there anything I can do to improve this? I’ve got Global Undo on. If I turn it off, then undo doesn’t work in Draw mode at all.

1 Like

I have seen that grease pencil gets better performance by disabling “post-processing” at the options top menu when you are in draw mode and setting active smoothing of 0.25 to smooth the strokes when you are drawing, not after. In extreme cases, I render a preview of the scene and use the image as a background image of the camera.

1 Like

I’m not noticing a difference from either of those. But I’m not having performance problems while drawing, just lag on the undo.

try switching to the workbench engine renderer i find that helps

1 Like

Hmm, doesn’t seem to have made a difference.
I’ve tried disabling all my addons, disabling cloth sim, deleting my rig, and more, and nothing helps much :frowning:

I’m hearing, and myself experiencing slow downs in viewports…its a beta after all…perhaps, jump back to a earlier beta build only suggestion I can think of.

1 Like

i think they are refactoring the code,before the grease pencil creates an empty as the Active object, but now seems the whole strokes are the active object and even outlines the onion skins as selected, this might cause over-draws which contributes to performance regression.

2 Likes

I was playing around with greasepencil today, and noticed a improved performance when you turn off anti alias
go to the engine setting and toggle antialias use workbench render engine…
also try minimising blender and then bringing it back to full size, it sometimes help

1 Like

No luck :frowning:

Sorry to hear that, have you lowered the viewport samples?

I do feel that it has regressed, so your not alone but I’m hopefull for a optimised final build

1 Like