Gtx 580 very slow!

Good evening,
i have a new Asus gtx 580 because i want faster rendering in cycles. But now the card i very slow. I looked for some benchmarks and an other asus gtx 580 had 3,5 minutes for the image, my card had 12minutes…

How can i fix this? I have the newest drivers.

My System: Intel i 5 3450 CPU
Asus gtx 580 direct CU2

Thank you very much for your help!

Just a few diagnostic questions to help find out what is wrong:

Did you enable the card under the CUDA setting in Blenders system preferences?
Are you rendering that test image at the same resolution as the others in the benchmark?
Is the card actually new, or is it second hand? - Not that second hand will necessarily be a problem but it may have taken a lot of wear before.

I had the same issue with a Zotac GTX 580 a while ago. That was extremely poorly designed but in the end still had the same issue. Sometimes the hardware is just faulty. If you cant get it to work properly return it to the seller and try again.

File>user preferences>system> CUDA > Geforce GTX 580.

On the right hand side of the blender default layout is normally world settings, object properties etc, go to the render settings which looks like a camera and under render, set device to GPU compute.

Right click on your desktop>nvidia control panel>3D settings> Manage 3D settings>program settings> add browse to where your blender.exe is located, then in the settings window set the power management mode to prefer maximum performance, apply the settings and restart your computer. If you don’t do this, your video card may be stuck at almost half of it’s clock speed because it thinks it’s in 2D mode.

Thank you for you answer, and yes, i have enabled the cuda setting. The card is new what can it be?

Hi nabiul,
thank you for your tips, i have done, what you said, but its still the same. Maybe you know the BMW Benchmark on this forum and i got 1minite and 15 seconds, thats bader than a gtx 570!!! Help me!!!

Do you have any monitoring programs to check what percentage of the card is being used and did you change the power saving settings like I said above?

yeah, i did. to solve the problem, i tested the performence of the card with gpu z thats the result:


the card is 98% used while rendering eith blender

Does gpu-z have graphs to monitor your GPU clock, shader clock and memory clock? Check what they are while rendering.

It’s difficult to tell what is wrong here, did you do a clean install of the drivers? How does the rest of your computer look, have you tried using cpu-z?

here are the clock speeds while rendering:


I don’t know what to tell you man, everything looks like it’s working right. Maybe try older drivers.

Or Beta drivers.

Or a non-x16 slot. When I slotted a second card into my old motherboard it dropped both of my PCI-e slots to 4x and severely slowed down my renders.

deleted reply…didn’t realize you already have the latest drivers.

Good luck.

Make sure your cpu’s gpu is disabled.

If you have more than one card, disable/remove and try in different sockets. Try and get you card tested elsewhere.

At the moment you are presuming your problem is the graphics card; when a system is displaying symptoms that suggest an error, it pays to identify the problem, not try and fix the symptom.

It could very well be the gfx card, but until you know what the problem is, you can’t fix it.

Symptoms are not problems.

How so?
The host<>device interface (the pci-e slot) isn’t used during rendering.
Only before and after.

A single PCIe 2.0 lane supports 250-500 MB/s.
A PCIe 2.0 x16 thus could have a maximum of 7.8 GB/s.
If it runs with x4 you could shove a max of 1,95 GB/s in the VRAM.

So, assuming you got an 1.5GB card, filling the VRAM takes either 769ms or 192ms which I’d call neglectable when rendering frames that take longer than 1s to render :wink:

During rendering, the PCIe interface isn’t used anymore, all is done on-device that’s why it’s that fast. For the GTX 580, the on device speed, or memory bandwidth as it’s called would be ~192 GB/s.

Once the render is done, the data, most likely a 100mb-ish image has to be sent back from the device to the host. neglectable again.

The PCIe lanes only matter for stuff where you need to constantly stream data, like games for instance, where you need to fill geometry and textures from the ram to the vram.

Try different tile settings when doing the bmw benchmark. In 2.64 my card gains almost 22 seconds from changing 8 horizontal and 8 vertical tiles to a single tile.

@nabiul

You should read the release notes. Tiles are no longer calculated by number but by tile size. If you still have it set to 8x8, it is calculating thousands of 8 pixel by 8 pixel squares at render time, which is very unoptimized for the GPU.

2.64 is using number, 2.65 is by tile size. I found 256x256 to work the best in 2.65, but performance is still lower than 2.64, cpu performance is almost 40% or more lower.