Guitar :o

Who can solve this problem? I set it smooth but that the front and back got like this and the sides are OK but when I set it solid the front and back are ok but the sides aren’t. Did try recalculating normals but didn’t work. Please help me! I’m about to finished something :smiley:


Try removing doubles and activate Auto Smooth. Does it work?

did you have all the vertacies selected when you re-calc’d the normals?

Did remove doubles but there weren’t any so no use. And where do I find auto smooth?

In F9, second panel.

SmokinJuan made a very pertinent question also.

I haven’t found a simple solution to this problem, but this is what has worked for me in the past if I had this problem. If you have a problem where some of the normals are backwards, and it simply reverses the problem when you recalculate normals outside/inside, try this: First, turn off “Double Sided” for polygons in the editing section. That has a tendency to obscure which polygons are really backwards. Then, select the problem faces individually and flip its normal to the same direction as the others (hopefully most of the rest are facing outside). If it seems to ignore your request to flip/recalculate that normal, then click “Draw Normals” in the editing window to see if the normal is really getting flipped. Set the NSize long enough so that you can see the normal (so it won’t be too short).

If that doesn’t work, go to anywhere where there seems to be a sharp or unnatural crease in the model and double check that you didn’t create a face at an extreme angle that caused it to twist that face. Either remove and redo that face or use the Smooth button in the edit section to smooth out the twisting to help with the editing.

See if that helps.

BTW, triangles and subsurfacing don’t mix well (especially with the way OpenGL is the basis for displaying the model on-screen, but it creates problems in renders too). Are you using subsurf, and if so, is your model mostly triangles or quads (e.g. 4-sided)? Ideally, they should be quads if you use subsurfs.

Of course, there’s always the possibility of driver issues or bugs… Does the problem go away in a previous version of Blender?

Sort of looks like you have 2 meshes right in the same place.

Put your file online. Instead of a guess, we can see the problem.

Well it’s solved already, needed to use the auto smooth

how did u get auto smooth working??? when ever i try, it doesnt work! i have a sorta tube thing. but i simple cant get the sides to be smooth and the top and bottom edge to be hard.

i remember around blender 2.37a, the autosmooth would have taken care of it no sweat! but now i cant get auto smooth working, no matter what i try, did you do something special? or did it do it all by itself?

i would greatly appreciate your help/advice

thanks in advance


nvm, found it out, i need to set it smooth, and enable autosmooth, otherwise it wont work anymore.