H.264 lossless output is not working

Hello,
When I render an image sequence in the video editor, it loses the quality of the video even if I check the “Lossless Output”. Any idea what’s wrong with my settings. Thank you.



I ran into the same issue when rendering to h.264, tried lots of settings, and eventually I just switched to AVI. The videos seemed to stutter alot when i rendered to h.264 as well, and with AVI it was very smooth.

I have some issue with H.264, too. I tried to export RGBA into lossless H.264, but when reviewing it in my Sequencer, it was no longer transparent. I had before successfully exported transparency into HuffYuv codec, showing up in my sequencer, but the sequencer had issues with some of the frames.
Can someone review my codec settings and verify this will lead to a transparent video?



[Update]
MediaInfo. This produced 4:2:0 YUV. It should be AYUV, right?

Format                      : AVCFormat/Info                 : Advanced Video Codec
Format profile              : [email protected]
Format settings, CABAC      : No
Format settings, ReFrames   : 1 frame
Format settings, GOP        : M=1, N=18
Codec ID                    : H264
Duration                    : 14 s 440 ms
Bit rate                    : 1 580 kb/s
Nominal bit rate            : 8 000 kb/s
Width                       : 1 920 pixels
Height                      : 1 080 pixels
Display aspect ratio        : 16:9
Frame rate mode             : Variable
Frame rate                  : 25.000 FPS
Color space                 : YUV
Chroma subsampling          : 4:2:0
Bit depth                   : 8 bits
Scan type                   : Progressive
Bits/(Pixel*Frame)          : 0.030
Stream size                 : 2.72 MiB (99%)
Writing library             : x264 core 148
Encoding settings           : cabac=0 / ref=1 / deblock=1:0:0 / analyse=0x3:0x113 / me=dia / subme=8 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=0 / me_range=4 / chroma_me=0 / trellis=0 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=1 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=0 / weightp=2 / keyint=18 / keyint_min=10 / scenecut=0 / intra_refresh=0 / rc_lookahead=18 / rc=abr / mbtree=1 / bitrate=8000 / ratetol=1.0 / qcomp=0.50 / qpmin=10 / qpmax=51 / qpstep=3 / vbv_maxrate=9000 / vbv_bufsize=1835 / nal_hrd=none / filler=0 / ip_ratio=1.40 / aq=1:1.00



Same problem here.

I’m shooting 4k video and just started to learn blender because it seemed like a really good and open source problem. I don’t wanna pirate so it’s more or less the only viable option I found, being a windows 10 user. Anyway…!

For MPEG-4, H.264 there seem to be a cap on the bitrate, no matter what you set it to it’s locked to 10 000 kbps.
What’s worse is that when exporting lossless .AVI the bitrate isn’t set to match the original content.

I’m doing high quality videos for youtube and it’s really beneficial to use MPEG-4 with the H.264 codec. But here’s the problem: Youtube compress your footage even more, so you want as high bitrate as possible when uploading, ideally the same bitrate as your original footage. For me, that’s around 92 000 kbps.

The problem with editing footage and then rendering it to one file in blender is that I can’t seem to do it without either blowing up the size of the file with super-high bitrate (with AVI lossless at 732 348 kbps) or downsizing it to something like 8 000 kbps (for MPEG-4 and H.264 codec).

Is there a way to fix this bitrate cap on the MPEG-4 format with the H.264 codec in blender? From what I can see on youtube videos tt seem to work fine to tune the bitrate to whatever you want using other editing software such as Premiere Pro with the same format and codec.

Can someone else confirm the bitrate cap so I know it’s not just me…
How do I fix this bitrate cap so I can chose whatever bitrate I want?

Same doubt here!