Hair mirror not working correctly?

Since I watched one of the Peach tutorials I wanted to try some of the advices they gave.
I tried to use the “mirror” tool in the particle mode, but somehow it does not work correctly (at least not for me) I am on the very latest SVN version, so maybe something is broken there?

Here is what I did.

  1. Used the default cube
  2. Created some hair particles (see picture for options, random and normal speed)
  3. Made the particle editable
  4. deleted the left half of all particles.
  5. used the menu “particle”-> Mirror or CTRL+M
  6. See the result, the lower left plane did not get any hair particles.

I got the same result in a more complex environment. Just used the cube for presentation.
Am I missing something, or is this a bug?



Hmm, nobody has seen this behaviour?
Is it only my compilation that is wrong?


You’re right this is a bug … though I would guess hair particles under a cube wouldn’t be a top priority … not too many people making beards I guess … :wink:

Well it actually was abug.
The cube was just an easy way to show it, it happens on a lot of faces in more complex models too.
I actually saw this on one of my models when the x-mirror Apply did not work on both sides, some strands where not affected.

BUT we do not need to worry about this anymore.
Brecht saw the Bug Report I created and fixed it.
It took him as little as 4 hours from my bug report to the SVN commit.

AWESOME… Brecht you are certainly one of the most incredible coders.

1 Like

I too am having the same problem with the Hair not being mirrored on other part or Hair appearing only on the Mirrored part and not the original.
How can I rectify the same or download the rectified Mirror modifier?