Hair on mesh is lumpy

No matter how many times I comb it, smooth it, or puff it, it always has these high and low places. At first I thought maybe its just the geometry of the mesh but at this point I have no clue. I’m trying to make fur for this character and it doesn’t seem like I can use the particle system. Is there a fix or an alternative?What do you think?

Go to the bottom of the hair settings thing, and you should see an option for “size” or something like that. Make sure that it is turned down. By default, depending on scale, blender usually does this really cool thing where it makes hair look like a spearhead unless you do that.