Hair particle bugged

(blendfile attached : )
My hair is very buggy and I wished my problems were solved, I really really need help on this.
I have a hairstyle composed of two layers, two particle system, one for the main hairs, and one for the frizzy hairs. The scalp where the hair is, has modifiers set up like this :


And here is a picture of the hair how I want em, and how I stylized em in the particle editor :


But this is how it looks when I disable the fluid modifier that the scalp has

And this is how it looks when I uncheck the “Dynamic Hair” box

Screenshot 2021-01-29 013121

I want to simulate my hair, but when I bake it, it comes out weird and deformed, plus, the main hair are static, there is only the frizz going crazy.
What am I doing wrong, please I really need help, at the end I want to be able to simulate my hair correctly, them looking exactly like the first picture, but without the fluid modifier, wich I think is causing problem in the sim.

If you can provide help, please do, It’s urgent, and I absolutely need this to get fixed, and If you can’t provide me help, like or upvote my post so that other users that can help, see my post.

(blendfile attached : )

Hey there, quick question, why exactly do you have a fluid modifier on the scalp?

1 Like

I don’t know, maybe I tried to do some smoke sims and didn’t removed it

I know, it’s a bit inattentive of mine

I took a look at your file but I think you might have to clean up your workflow and maybe try the hair dynamics principle on a simple case before applying it on a character. There are too many things that might be messing up the hair that it is hard to say what is the root of the problem.

You definitely do not want a fluid modifier directly on the scalp of the character (not really sure what would be the use case). IF for any reason you really need those fluid and collision modifiers make sure the modifier hierarchy is optimized (if the fluid modifier was last it would not affect your hair grooming… that is the reason why turning it off and on changes the hair).

If you want collisions with the head, hair should not intercept the head in places where it is supposed to fly around, otherwise it will get caught up and do weird movements.

The reason I cannot help is because I do not understand what happened to the hair edit, when I select the scalp and go into hair edit there is nothing there, not sure why but that is not normal behaviour.

One last tip, when working in the viewport, do not crank up subdivisions :slight_smile: there is visually zero difference and its only slowing down your viewport performance with 16 times more geometry that changes nothing. Specially if you want quick feedback and experiment with parameters.

1 Like

Ok first, thank you for your time, second, I want to remove this fluid modifier that I don’t need, but I cant, because it changes my whole hair style, so how can I achieve this ? Sorry I didn’t prepare the file well, you have to set this to particle and not cloth, my fault

I mean, I didn’t solve my problem, but If you want to see the particles you gotta change the option, in order to investigate better