Hair Particle System Inverted?

Hello, I’m currently working on a fawn model and I recently added a particle system to the mesh. I made a vertex group labeled “Hair” and applied the particle system to the vertex group. In some sections of the mesh, rather then the hair emitting the way the face is facing, it’s going in the opposite direction as shown in the image below. If anyone can tell me why this is happening it would be greatly appreciated.


Are all the face normals pointing outwards ?

For some strange reason there was no demo .blend file supplied with your post, so we are unable to check this

Yes, all the faces were pointed outwards. And that probably was rather stupid of me not to link a blend file with it. Here it is.

Well to begin with, I would change your modifier stack order and move your particle system above your subsurf. I think you will find that is most of the issue. You have your use modifier stack checked and Blender is trying to guess where the subsurf vertices might be. It’s not real good at that guess. Then you might want to go back into your particle edit and add a few more parent hairs in critical spots. Nice animal.

So I tried what you suggested and switched the modifiers stack order, it didn’t change much though. And The problem isn’t that here aren’t hairs there, the problem is that the hairs are on the other side of the face, See the image below. And thank you for the compliment.


Ok I think I finally see what your issue is. Your talking about the bald spots say inside the ear. If you are indicating the areas where you have sharp curves, the particle system is trying to average the normals there I think and is picking a different one that what you see. I have a couple possible solutions. Go to advanced and uncheck random and even and tweak the normal directions. I think a better solution however is to set up more than one particle system and for instance pick faces that are not so much at an angle. Say the inside of the ears without the edges selected for a vertex group. You can put several together for one system.

I am having this issue. The hair “object” particles are coming out the underside of the object and not the top. I would provide my .blend file but I am a new user so it won’t allow it. How do I select the correct side of the object? Sorry, I am a total newb on Blender. :flushed: