Hair particles not refreshed with animated texture


I’m completely locked in a big project by two bad bugs with static particles (hair particles) driven by an animated texture. The particle system is not refreshed when changing frame, and the Density button of the Map to Panel is no more active in Blender v2.49a.

So far, I have got no response from the Bugtracker. I don’t know if the Bugtracker is only active during Release Candidate periods, or if the developpement of Blender 2.5 has put 2.49 in a shadow area, but if they are not taken in account, these very annoying troubles could be transferred in 2.5, and not solved before 2.5a !

Reported as Bug # 19037.

So, if you can help in any way, please read this thread :

Thanks in advance.

Best regards,



I think I found a work around for your density bug.

Your right, it does not work at all in 2.49, but it does still work in 2.48 (the density).

What I did is wrote a script and placed it in the frame change event of Blender 2.48. All the script does is take the selected object and put it in and out of edit mode. This actually worked, I could see the tracks moving through the particles.

So if you are willing to downgrade to 2.48 and try out the script, it may be a solution for you until the real bug is addressed.

import Blender
from Blender import Window,Scene

print "->Frame Change"
scn = Scene.GetCurrent() 
obj= scn.getActiveObject()

Place this code in a text window and assign it to a frame changed event in Blender 2.48.

Thanks you very much Atom !

Your script works fine, and it will save my project while waiting for a bug fix release !