Hairnet addon installation problem

I downloaded the ZIp from github and installed it like every other addon using the install addon button in the preferences. No error messages, no warnings, Blener console says Modules installed but no Hairnet shows up in the addon list. I tried it in 2.79 and 2.8, same result. Please help.

I have the exact same problem. I’m using Blender 2.79b and I cannot get the addon to work at all.

I’ve tried installing it via user preferences, nothing. I’ve tried just unzipping the folder and placing it into the addons folder manually, same result. I even uninstalled and reinstalled Blender, didn’t help. Restarting computer didn’t help…

Can someone please help me solve this?

Welcome aboard, Suraia!

Looking at this addon, I think you may only need to install the .py file as an addon rather than the .zip with the .py in it. This is an issue with github - it’s never clear what you should be downloading as the addon.

Failing that, it would probably be best to contact the creator of the addon through Github, or BlenderArtists - Hair guides created from mesh objects - but it looks like the last update was 1015, so I wouldn’t guarantee anything.

1 Like

Thank you for your reply,

Now it does show the addon under User, but as soon as I click on it to enable it I get a traceback error. I can’t find any of this on the internet.

I’m no expert at coding and this I don’t know if this is something I can fix myself, or if it’s the code and needs to be changed.

At this point I would get in touch with the addon’s creator.

I thought so too, thank you again for the help.

Hey Suraia, you might want to take a look at Hair Tool. It works in 2.8, is well documented and does everything and more what this script porvides.

I have it installed fine,but mine is from an older addons_contrib zip from blender site.I never tried updating it,cause it’s updated for 2.8,and some addons for 2.8 don’t work anymore in 2.79

for reference,my hair_net version is 0.5.1

Seems the version in May 1 daily build of 2.79’s addons_contribs works with stable release,so far.So it must be something they are tweaking and breaks off and on.Keep trying daily ones til it works,and don’t worry about updating.

Having the same problema here. I can’t manage to make it work. Even though blender says it’s corrected installed (but doesn’t appear in addons), and it is actually installed in the folder in explorer.

Sorry about this, everyone. In hindsight, I should not have uploaded the most recent code changes that I’ve made since HairNet and Blender 2.8 don’t work yet, and the most recent version of HairNet doesn’t work in Blender 2.79.

HairNet 0.5.1 is the only version that works, and it works in Blender 2.79. You can find it here:

I’m sorry for the problems. It was not a smart choice for me to have created them.

Hi, love to test this addon but HairNet 0.5.1 on Blender 2.79 not work also.

Here is the one I’m using,in addons_contrib from May 1,prob same one,or just slight difference (36.2 KB)

I use official release of 2.79b,and deleted all pycache folders,incase something was causing issue,and seemed to make it work,hopefully it helps others.

1 Like

I also just realized that GitHub’s “Download Source” links won’t install properly through Blender. I added a ZIP file to the 0.5.1 Release that should install correctly.

I have download the version from the github page And install the 0.6.1 version as normal addon. But its not visible in the addon list to activate. Im using 2.82 version. Any help to install the addon

1 Like

There is only one “” in the zip (a little unfortunate). See also @yogyog. You can extract it and e.g. rename to . Better a subfolder in the addon folder e.g. Hairnet, then copy the “” into it.
Edit: Blendernation does not appear to represent underlines.

I’m having the same problem

Could you elaborate a little more I tried making both the init python file but usually they are 1 KB and then the actual file is bigger. I’m not sure if I’m following your directions properly

Never mind I just changed the name of the file. I don’t think the installation was calling the file properly. All I did was change to Thanks everyone for your help!!!

Thanks it visible now. A question for human hairs its ok. But for animals like dog. Im working on dog model how can i have hairs on full body.

So, you download the file here:

Then you extract the .zip.
You will have an unzipped folder called “HairNet-master”
inside is a folder called “src”. You rename this folder to e.g. “Hairnet”
and zip it again (only that renamed folder). Now you can install the addon as usual. But it might be easier to rename the " in the “src” folder to e.g. “” and install it (only the “”). Hope this explaint it better.

1 Like