Halo Volumetric Lighting Problem?


(imatthew) #1

I hae set up a plane with some text cutting thru the plane. I put a spot light behind the plane and would like to get the effect of light shining thru the area cut out from the plane.

I have seen several tutorials on this subject. I have the Blender Book in front of me with nice examples of this exact set-up working???

But my efforts always leave me with a round cone of volumetric light that dosen’t seem to care that there is a solid plane sitting in front of the light?

It is like I can see the beam of light through the portions of the plane that are opaque.

Can anyone shed some light on this problem?


(Psilocybin) #2

If it was a volumetric light the light would be effected if there was a solid plane in front of it. So you are not using volemtric lights or I don’t get it either. I only what a volumetric light is and I have no experience with light in blender so I am not the best person to say. Are you sure the light and the mesh are connected in some way or is the plane somekind of surface that doesn’t allow lighting?


(IanC) #3

In the light settings, set “halo step” at the bottom to 12 for a good render or lower for lower quality.

HTH, Ian


(rwv01) #4

Problem is there’s still no shadow.


(meestaplu) #5

Bulletdodga wrote:

In the light settings, set “halo step” at the bottom to 12 for a good render or lower for lower quality.

Actually, that’s not quite true - everyone gets this backwards. :wink: Halo step is a bit backwards. Setting it to zero means that only a conic halo will be rendered. A value of one means that high quality volumetric shadows will be rendered; larger values decrease the quality.


(rwv01) #6

I don’t think that’s imatthew’s problem though.

You can reproduce the issue if you start new and add one plane as a background and another in the foreground. Then add a spot light and a camera set up so you should see a shadow. But there is none. Why?

tracable check
enable shadow check
let lamp produce shadows check
add materials check

What’s missing?


(imatthew) #7

Okay it is really frusterating because I copied the example from chp. 7 of the Blender book. It works. I even changed the plane to be the one that I want with a different cutout.

I keep flipping back and forth from the two files and the one I made as a big cone of blobby light that justs seems to disregard the sold plane that is blocking it from the view of the camera.

There must be some other setting that is doing this? Maybe something that isn’t in the lighting buttons?


(IanC) #8

I dont know, this affected me when I first used blender, I had to get the lights from another file at first but not they work for me. I will send my starting file to anyone who is having trouble to see if that works.
hth
Ian


(rwv01) #9

Woo Hoo!

Turn on the shadows button in the next to the big Render button!
(or is this way off?)