Harmony build crash

So i just downloaded the latest build of harmony and everytime i play the game then hit ESC it chrashes and comes up with the standard win 7 thing where is says close program.

Im on win 7 latest build of harmony and thats it i guess. oh and it does this on any blend file.

Yep I get this as well. It also happens with xp 64bit and ubuntu. Kupoman said it might be a bug with bmesh. I can sometimes get it to not crash, but I cant reproduce it often enough to make any sense of it.

Been there as well, but with a 2.62 GraphicAll download. Made a post about it awhile back - Moguri mentioned that it might have been due to the BMesh merger, and that we should report the bug to the Blender bug tracker. However, I can’t really find a way to reproduce it reliably - it would seem that running the engine normally works fine, but game logic breaks it…? I’m not very sure. Maybe I’ll report it with a sample blend file.

Also on Windows 7, 64-bit version.

Just tried another build off of GraphicAll. Instantly crashed when trying to run the BGE with one of my old scenes. Trying to save a scene in the old version of Blender also didn’t work (I thought it would, though). This bug is hard to track down. Hopefully someone has a simple enough scene that they can share with the bug tracker.

EDIT: Oh, and don’t save over blend files with the BMesh merger, as I believe it will delete all faces in older versions of Blender.

:eek: how old are we talking here? Just before the BMesh merger or way before that? Yep I really hope that this bug gets sorted quite soon. I seem to get this error with any file, even the factory default cube, when exiting the bge it crashes. I’m going to send a bug report ASAP for this. I hope its an easy fix the devs.

im on the latest download i just downloaded it 2 days ago

that’s happended to my with 2.62 official build

2.61, I think? Good to know that it’s repeatable, though. Should be somewhat easy to fix.

I was wrong i guess it for me only does it on my SWAP blend files but any other blend its fine on. well this gives me a ascuse to work on a game idea untill its sorted out.

I dont know how to spell ascuse lol

Well, Bmesh hasn’t been in an official release yet (2.63 will be the first release with Bmesh). So, it seems something else is going on for some people. The first step to hunting it down is reproducing it though.

what if i sent a message to who it is that was working on the branch? i cant remember his name.

SolarLune what GFX card you using? I quickly tried it on my laptop and I wasnt getting the problem. My laptop doesnt have a dedicated GPU and my desktop (which is where the problems at) has an Nvidia GTX 580. Maybe a GPU problem?

Getting directly in touch with the dev would be great, but I have no idea who works on each section of the branch.

I have a Sapphire (ATI) Radeon HD 7750 graphics card.

well i think he has posted on the forum if its the guy im thinking of his avatar pictur is like a guy with a top hat or something.

mrn: Both Moguri and myself are working on Harmony.
Have you tried your file in a comparable non-Harmony build? As others have suggested above, this crash may not be unique to Harmony. Harmony just happens to built on a version of trunk that is after the Bmesh merge (which has caused some issues for the BGE).

ok i will try that. the only thing is that i need it to be in the harmony build because ive done the rest of the game in that and i need the soft shadows and things. that i cant do in the regular build.

I have tried my files in other versions of blender, including the latest build from the svn of the trunk. And I have double checked and I do not get any problems on my laptop with the latest build from the harmony branch. Is it maybe something to do with being run on a 64bit system? My laptop in 32bit and my desktop is 64bit.

Also does blender log errors to a file somewhere? I havent seen anything flashing up on the console just before it crashes and closes. I even screen captured the console at a high fps to see if my eye was missing something, but I couldnt see anything when scrubbing back through the video.

I am in love with the harmony branch and am desperate to help get this sorted. I still havent had a chance to bug report as I have been away from my desktop (the problem machine) so havent had a chance to make a video or .blend file with the problem.


ok so i looked in the console and i found this error apear when i start the game engine. I have no idea what it means or if its anything but anyways here is a screenshot maybe it will help. Oh and also if i create a new blank scene within the same blend, then inside the new scene run the game it and exit it works just fine.


Yeah me to, as i posted on graphicall under comments i have same issue with Harmony on x64 ATI 6770 M :confused:

When i run my forklift simulation everythin is fine no messages in console, then when i try to exit it…Bum crash.
Also in console is reported like always: “Blender Game Engine Finished” and after that crash.

But if i try to run some default scene with shadows and that it works okay no crash on exit :confused:

ya this is really frustrating, i cant work on my game at all.