Having problems starting it

Suddenly earlier today, my Blender just up and quit for no apparent reason, saying that it had encountered a problem and needed to close, and now it refuses to start again, even after a clean reboot. Reinstalling it works for one program start and no more - it’ll open the first time I run it after a reinstall, but after that it gets the same thing.

I’m running 2.0 ghz, 1.5 gb RAM, Radeon X200 series video card. I downloaded Blender 2.45 a while ago, but I don’t think that’s the problem since it ran fine for several days before giving me this issue. I don’t see what could be wrong, it just up and decided to die.

Any ideas for how to fix it?

Find and delete the file B.blend, then launch Blender again.


Search function is coming up with no files called B.blend. Why, would there be something wrong with that?

the file is " .B.blend ". spoken> dot B dot blend
some people claim it has magical powers.
more realistically, it contains data & does not uninstall or is left over during the uninstall process & apparently is not overwritten during re-install.
if the data it contains is corrupted it will remain to bug you.
the best way to avoid this is to delete the entire
C:\Program Files\Blender Foundation " Blender Foundation " folder & truly start anew.
or just delete the .b.blend file & re-install, either way works.

You must be on a Mac where dot files are hidden and you have to jump thru hoops to unhide them. Search “dot files” here where the process has been explained. I don’t have Mac so I can’t explain.


Ahhh… that would be why deleting the Blender Foundation folder made it work. I did that before you guys even posted that and said, huh, wierd, it suddenly works now…

Guess thats why…

Any way to stop it being corrupted? Because it happened again after a few hours of use. I think it may have something to do with saving, because thats what I’m doing whenever it crashes.

Thanks for the help guys! :smiley:

Edit: Nope, no Mac for me, I’m running XP.

Sorry for the thread necro, but I figured it would be easier to ask again in this thread rather than start a new one.

Well after nearly a month of good use, it’s happened again. I still can’t seem to find .b.blend, and I’m getting mighty tired of deleting the Blender Foundation folder and installing again. Anyone know where in the folder I might find this file, and how to view it in XP? Also, since it always seems to cause this while saving files, does anyone know how to…well, not have it die while saving files?

I think it might be hidden then. To make it show hidden files, open Windows Explorer and go to Tools>>Folder options, click the “View” tab and look for the bit that says “Hidden files and folders”. There’ll be two radio buttons here, click the “Show hidden files and folders” one. You should then be able to find the file in Program Files\Blender Foundation\Blender.blender.B.blend.

C:\Program Files\Blender Foundation\Blender.blender
is the folder.
although it could be that the file does not exist until you press ctrl/u to save user defaults.
could someone confirm this?
I did a fresh install & the file only appeared after ctrl/u.
in that case no wonder you can’t find it.
so it could be that you are doing something else to crash Blender.
how big is the file you are saving?
can you post it?
have you pressed ctrl/u with a large file open?
that would be an explanation, if you saved a very large file size as your user defaults, Blender or your computer may not have the power to open.
don’t save user defaults with files open.

Doesn’t show up still.

I’ve never even used ctrl+u.

There’s a lot of different files I have that saving makes it crash, of any size.

Wierd thing, though…opening a new file and just saving that without any changes (just a blank cube) seems to help when its the first thing I do after an install. If I try to open another file and save that first thing, or just open something and then close it without saving first thing, it kills it again. And then of course it’ll just do it at some seemingly random time some time afterwards. :spin:

Edit: Also when opening certain files, it says “file written by newer blender binary: 25964.25710; expect loss of data!” and then dies. Any ideas?

Many apologies for the bump, but I want to get this issue fixed! :frowning:

Also when opening certain files, it says “file written by newer blender binary: 25964.25710; expect loss of data!” and then dies. Any ideas?
Well, that means you’re opening a file that’s been saved using a newer version of Blender in an old version, which would probably cause problems. I think there was a thread about this somewhere saying 2.44 files are incompatible with Blender 2.43 or something like that. Have you recently started using an older version of Blender, or even just a different version?


I downloaded Blender 2.45 a while ago

That could be your problem. See if switching back to the version you used before helps, 2.45 might not like your computer for some reason.

This started like, a month after I started using 2.45. But for that entire first month, it never gave me any problems whatsoever.

Have you tried using any builds from Graphicall or anything? Maybe that’s it? Anyway, like others said, I’d still be there’s a rogue .B.blend somewhere. Many times Windows puts this thing in your “Home” folder. It’s probably buried in some “AppData” folder somewhere under there.

Search your entire C: drive (and any others) for an .blend files. Then see if there are any b.blend files to delete.

I’ve honestly never heard of this problem before and would guess something to do with permissions or something on your machine.