Having Trouble with EEVEE Shadows

I have been trying to produce hard shadows on EEVEE using a sun lamp. it looked good on the viewport but in the render, it didn’t give the same result.
these are my light and shadow render settings:

Render and Light Settings (in the Album)


Final Render
Imgur

Hi. Could you share the .blend file?

sure.

One thing is to reset your sun angle to zero.
Quick Render…

Camera is set to Orthographic type. Have you set this up intentionally?
The same thing happens in viewport if you switch to Orthographic mode (key 5 from numeric keypad).
I have no idea why shadows act differently depending on Orthographic or Perspective view. You should report this just in case.

yes, i used Orthographic on purpose. Thank you for your response.

Read this:
https://developer.blender.org/T63666#666194

From camera settings, in Clip End set a not big value (100m for example)

the problem was with the Orthographic camera. I guess now i have to get rid of the Isometric look in order to get the accurate shadows sadly.

i just remembered i could do that, and came here to leave a comment xD
thank you for your help :smiley: