HDRi lighting: .jpg is OK, .hdr is very noisy


I followed a tutorial on Blender Cookie about HDRi lighting. I used the exact same node setup. Render 1500 samples (pretty high). As you can see the render with the .hdr contains much more noise. How to fix this? What’s the reason?

Did you enable multiple importance sampling in the world environment tab? i usually set it to 2048

I NOW DID! The result is amazing!