HELP! Armature Hidden and I can't get it back!

The problem is in the UI (User Interface) of your blender file, open a new general file, click file > open > don’t save the general file > after choosing the file you want, click the gear icon (top right), it opens a window , uncheck (Load UI). And now if you create Armature you will see it.

You saved the day! Thanks!!