HELP! Armature Hidden and I can't get it back!

Can someone help me I hid my armature and then selected something else and now I can’t get it back. I tried Alt H but it didn’t work please help :eek:

How exactly did you hide your armature? It’s hard to solve a problem if you don’t really describe it.

Perhaps your armature is in another layer, try searching those.

If you hid your armature using h or shift+h make sure you are either in edit or pose mode, because you can’t hide and unhide things in object mode. Also make sure you do have the armature selected.

Hmm I don’t think my problem is fixable. What I did is use H to hide all bones in pose mode. Then I selected another object. The armature stayed hidden so that means now I can’t reselect the armature to unhide it. I think this is a bug because I can’t see any way to unhide it and it should be like when you go in edit mode with a mesh and hide vertices and go back to object mode and they’re all there. If anyone can find someway to unhide it that would be great because then I won’t have to revert to my earlier version.

P.S Where do I report bugs anyways?

You can select the armature using the Outliner view, and then should be able to unhide.

Outliner? Bounding box or wireframe?

The outliner isn’t in the 3d view…its a completely different window type…like the nodes window or the script window or the uv/image editing window. It shows an outline of all of the objects in your scene…

Hope this helps!!!

-Chris

Well none of this helps now because I am impatient so I started from my other version. I went into the outliner view to test that idea though and found that you can’t select objects with it. I may be wrong cause I only had a short look and I’d never used the outliner before but it seems it only lets you view objects, not select them.

What version are you using? Also what do you see in the outliner window, an explorer like structure or rectangles connected with curves? If the latter go to view -> show outliner. You should be able to select your objects then.

if you hide armature ends in edit mode, when you leave edit mode, the outline of the object, and the object center, are re-displayed. The only way to hide them outside of edit mode is if they are on an un-selected layer. Have you tried pressing tilde (~) to select all layers?

I know what you are talking about. I was in pose mode and since I wanted the bones out of the way for the moment I hit “A” to select all then “H” to hide. I should have just done that from the object mode not the pose mode because now I cannot find a way to get back into pose to unhide all the work I have done.
So yes, I too have lost my armature in the same way.
Anyone know how to unhide bones that were hidden during pose mode and not object mode?

Update: Never mind. I figured it out.
Go to the “outliner” window and you will see “armature” with a few pictures to the right. Click on the one that looks like a little person. The armature became visible and selectable.
I then selected one of the bones on my person. From there I was able to go to pose mode where it was still hidden when I selected that mode (it dissapeared) but I hit Alt + H and it came back.

3 Likes

I am having this exact same issue. VERY inconvenient…

I don’t understand the solution you described either. I open the outliner window, see the armature datablocks button on the far right, clicked it. I see SOMETHING pop up in that window, but its so friggin small I can barely see it. Anyway, I can’t get into pose mode or anything, so Idk what to do here.

SOLUTION! (for Blender 2.49 at least)

Ok, just so this is cleared up with everyone in the future, IF you hide your armatures in POSE mode and cannot unhide it, do the following:

  1. Open new scripts window and select “outliner”.

  2. Click “view”, then “show outliner”.

  3. You’ll either see your armature in edit mode… or you’ll be in pose mode with your armature still hidden. Either way, get into pose mode, then hit Alt+H.

Problem solved.

Thanks, you solved my problem as well

My problem is not 100% solved by the comment here.

So cold sweat emerged…that sinking feeling. But suddenly my spirit told me to acces the armature window, via the outliner menu.

I accidentally unselect the layer of them bones. I clicked and Voila…it reappears. Yaaaay!

Hope this is helpful for them ones having problem beyond the H button.

Cheers

I had this problem turns out I didn’t relise that I was looking at another layer (everything was on layer 1 and I for some reason was on layer 8 or something) swiched it back and could see the armature again!

Thank you so much! Was really worried

In my case I had accidentally left the armature in local view. I was able to troubleshoot this by looking at the Blender File in the Outliner, saw that the armature was still there, and kept trying to click it/select it, then finally realized in the top left of the 3D editor it said it was the active object in User Perspective (Local).

okk now how do u change that , im new to this ?


I have had very strange issue with weight paint and now lost the armature lately, the only way to get it back is append it from a new file.