HELP: Artifacting Problem

Anyone know how i can fix the artifacting going on here?.. I’ve tried increasing the sample sizes (no difference), i have the denoise filter in composite setup, i’ve removed caustics. dont know what else to try. Any help would be appreciated.

New members cant upload videos so this is the best i can do:

You said you increased the samples, but this looks like what happens to a denoised noisy image. Whats your lighting setup? are you using all 3 inputs on that node, or just the image? Small point lights, lights going through glass materials, emissives w/ small bright hotspots can all cause noise like this, even when there appears to be enough light. Can you show an image of it before denoising?

Yeah your right, I wasn’t aware that denoise essentially blends the noisy pixels by blurring them together which essentially creates the effect above in an animation. Essentially good for a still image but not for animation i guess. The scene has just two lights which are blackbodies, one cold one hot for composition, no fancy effects like glass or emissives. Eventually i found out that darker scenes require more samples, so i took it from 512 to 2048 and it seems to have fixed it. I’m not sure if theres a better way because im still very new and my render time went from 15sec per fram to almost 3mins with 2048 samples. Here are the images one of them is at 512 samples the other is 2048 plus my finished render.

Instead of using the compositor denoiser, use the open intel denoiser built into the render panel and disable the compositor one. I have found this denoiser to much better suited for animation and just better overall.


Adding more samples is always going to help especially in dark scenes. But I have had really good results with the open denoiser. Just make sure you disable the denoising nodes in the compositor.

1 Like

hmmm interesting i’ll try it out now thanks i’ll let you know how it goes.

wow thats amazing, I dropped it from 2048 to 512 and its almost the same, only slight amount of noise. Thats incredible considering at 2048 it took nearly 3 mins per frame and with that denoise you told me about i dropped it to 512 frames and it only takes 40 secs per frame… heres a 256 vs 512 sample comparison i did using that denoiser… thanks a lot!! that will help massively.

1 Like

Yeah it’s pretty magical. Are you using the Cycles X branch? You can probably cut your render time in half or more with Cycles X. It’s also magical.

Its here if you want it. Make sure its Cycles X and youll need to migrate your settings and probably re enable Cuda.

1 Like

Do be careful with experimental branches tho, I’d save a duplicate copy of the scene to use with the experimental branch. Less risky.