HELP - Blender Fluids AGAIN!


(probiner) #1

After the liquid fills the cup it does not look smooth over the cup’s surface. Any tips on how should I improve the sim?http://blenderartists.org/forum/images/smilies/sago/spin.gif

http://i153.photobucket.com/albums/s202/animatics/Lightwave/fluidism.png

Thanks.

Zip file with scene and sim frames 1-2-3-60: http://www.mediafire.com/?hd1e9k0112f7442


(Richard Marklew) #2

Add a link to your blend file if you want help. There are so many settings for fluids that a single screenshot is not a lot of use


(Peter18) #3

if its a cup, surely you wont see the sides? also you have posted this in the wrong place :slight_smile:


(probiner) #4

Ok, I understand that, I have put a zip file on the first post. Zip contains: blend file, frame 1,2,3 and 60 of the simulation. Thanks.

Thanks for telling me I posted in the wrong place and not telling me where the correct place is, bright person from Brighton :slight_smile:

The cup is made of trasparent glass, so it is a problem.

Cheers


(Isaak) #5

If you are rendering a still, hide the Cup and smooth it in sculpt mode.


(probiner) #6

Not a still, but thanks for the suggestion


(Wasabi2007) #7

One suggestion, is the cup rely 2 Meters?


(probiner) #8

The Domain’s geometry mesh is 2m in blender, while it is something like 50 cm in real world size, so I could change that to something like 0.5m instead of 2m.

But I made a quick test with a faster fluid and 300 resolution instead of 700 and still looks like the voxels skin don’t stick to the glass cup…

http://i153.photobucket.com/albums/s202/animatics/Lightwave/snap2.png

How much this REAL World value changes things? Anyone with experience on this matter? =/


(radialronnie) #9

The real-world value changes this considerable. Think of how a bucket-amount of water falling and hitting a flat surface would look different from a spoon full of water hitting said surface. The physics are different with different sizes; that’s true for everything, not just water.

Not directly related, but think of a cow falling out of an airplane; when it hits the ground, you have a beef-flavored splat. An ant could theoretically jump off an airplane, hit the ground, and continue walking.


(probiner) #10

I get that RadialRonnie, still The difference was 2 to 0.5 are you suggesting I go with higher number even if unreal like 10 or 20 to get better results on the way the liquid sticks to the glass cup surface?

10 or 20 would probably also make the SIM slower I guess, because suddenly the water going top to bottom of the cup would be the same of going along 20 meters in time.

Anyway, still no clue how to fix that problem with the glass cup surface and the filled liquid surface not being ‘glued’. I could solve it on render but would kinda prefer it solve on geometry for more consistent results.

Pulling my hair here. I find strange that this is not a common known problem, with a fix in place.

Cheers


(probiner) #11

Bump.
Because… i’m on a schedule =/


(NinthJake) #12

That problem was in Andrew’s recent tutorial, I believe that the only solution is to add more resolution to the bake but don’t take my word on that, watch the tutorial instead.
http://www.blenderguru.com/videos/create-a-realistic-water-simulation


(probiner) #13

thanks! watching.

I can solve it with render boolean, but would much prefer to have a fit geometry has it would make the render boolean even more successful if I choose to go down that path.

Cheers

EDIT: well hes using it for a still so yeah he goes different ways =)


(NCubed) #14

I think radialronnie is right (hi rr!), your Real World size allows all those bumps. Is your cup really half a metre across?

There was a quick tutorial on BlenderNation which gave some useful values.


(JuanJosé Torres) #15

Smooth is the key word here, guys. Forget Real World size and fluid resolution, those are dead ends (and very time consuming in the case of fluid resolution).

The artifacts your fluid is suffering appear every time the fluid is in contact with an obstacle with slanting surfaces, and this will happen no matter which resolution you choose for your simulation. However, you won’t see these artifacts if the obstacle surface is vertical or horizontal.

By the looks of it, I’d say this is a bug in the fluid simulator. Ideally you should be able to create a simulation out of the box with the default cube as a fluid domain with default settings and slanting obstacles without ever seeing this kind of artifacts.

But I’m digressing, and you want a solution for your problem. So far, the only way I have found to solve this is following these steps (screenshots are from your blend file simulated at 300 resolution, I’m not at home with my computer so I couldn’t bake any higher):

  1. Search for “Domain Boundary” under the Physics tab of your fluid domain. There you will see the “smoothing” parameter (set to 1.0 by default). Max it up to 5.0.

  2. Bake your simulation. You’ll get something like this:

http://www.pasteall.org/pic/show.php?id=23242

Which is an improvement, but not a definitive solution.

  1. To give it the final polish, add a “smooth” modifier to your fluid domain. Optimal settings may vary depending on the mesh, fluid resolution, lighting, distance from camera, etc. I suggest you experiment with them. For this case I used factor 2 and repeat 6 to get this final result:

http://www.pasteall.org/pic/show.php?id=23243

Bear in mind that using the smooth modifier, you will lose some detail in your fluid simulation, as well as some volume. Very small drops might even disappear if your overdo it, so you must try and search for a setting that both looks good and doesn’t decrease realism in your simulation. Hitting the sweet spot is simply a matter of experimenting with factor and repeat values.

Hope this was useful for any of you, guys.