Help I don't know what happened with my topo

So I was modeling a night vision goggle and this is what happened:


I don’t know what happened and how to fix it. Also, do you guys know any way to make the non subdivided cylinder a subdivided smooth looking one? I added bevel modifier and it doesn’t look the way i want.
nightvision.blend (843.8 KB)

it’s just that all this series of edges are not flat, so you need to select them and press S X 0 to flatten on the X axis:

I don’t really understand what you mean.


tried that and it made it worse

  1. Remove the Bevel modifier or set its Limit Method to Angle
  2. Delete these faces:
  3. Select these edges:
  4. Do a Face -> Grid Fill

Don’t just assume a tool or a modifier would “just work”. Look at the options and see if there’s anything you need to adjust.

sorry for not being clear, Stan has explained what I meant