Help making a steel grid floor please

Hi All,
I need to make my space ship floor like this if possible? I do not know where to start on this. I tried making a grid with a box flattened and looped… but not what I was looking for. Any help, direction, tutorial is appreciated. Here is the floor I had in mind.

Here is the floor I need to apply that to. If I had a picture of it I guess I could just apply it like a material. One square I could just multiply…

pretty simply all you need is a couple of cubes and some array modifiers, I cut the holes with .9 scale cubes scaled up a bit on the z axis.

Hi John,
Thanks for sharing that can be done. Not sure if you are willing to share the steps you took to do so. I realize you wrote what you used, but I am pretty new to Blender. Not sure if you shared that blender file if I can figure what you did by looking at it?


I think an easy method involving basically only keypresses :

A plane

Press W -> Subdivide, then press F6 and set Cut to 9

Press I 2 times (for individual Inset function) and inset just a bit

Press F6 and -deselect- “Select Outer”

Now press E and extrude down

Select All and press CTRL+E -> Select Boundary Loop

Press E , then press S and scale a bit

Go to Object Mode and add an Array modifier set it up like that :

Add a 2nd Array modifier set up like this (note on both modifier Merge is enabled)

Apply both modifier, then back to Edit Mode
Select all and press CTRL+E -> Select Boundary Loop

Press S and scale a bit

Go back to Object Mode and play again with Array modifiers

edit : oops forgot the little indent

So when you’re at this stage

Press E and extrude down or up a little bit depending on the effect you’ll like to do

After that, continue the same

AWESOME! Thanks Sanctuary, you rule!

I do have 2 question. When I add a plane to my existing model as you’ve demonstrated above. My plane is very small and when I use my mouse wheel to zoom in. It scrolls off view and I cannot find it?

The other is your hit the i I or | the first is a lower key “i” and the second is a capital “I” the third is the key next to the R.H Shift key on the \ key…

Yeah… just like that… Good tute Sanctuary! @netcommercial… Be sure to be careful when adding objects… if you’re in edit mode you’re adding the object to the current object, when you’re in object mode, you’re adding a new object (which can be joined (control+J in object mode with both objects selected). what you should be able to do is go into object mode, select the object you wish to work on closely, then click the period key “.” and your focus will be put on that object, you should the be able to zoom in on it.

I figured it was the key stroke " i " but you lost me here… How did I miss the “unselect the grid” or “inside lines” and keep the faces hi lit?

John L thanks for the ( . ) period key tip… AND the diff of object and Edit combine or not

Oh god got it Un click outer… Duh! Good grief

If the F6 menu does not display the options of the Inset action, it’s because you did something else after validating your inset.
Blender display the options of a specific function only -after- doing it.
But as soon as you do something else (by example you have made a “select all” after doing the inset), you will not be able anymore to access the inset options

So in that sequence, press i then press i again , to do the individual face insetting.
Move the mouse slightly to do the inset then press Enter or Left Click to validate the inset.
Now do nothing else, and press F6 , you will then have access to the Inset options.

edit : good you figured it out on your own

Yep, no problem… also, all objects (including camera’s, text, lamps, etc, all have an orange dot that represents the object’s “center point”. rotations, translations, scaling, etc all depend on this point. So… if you’re in edit mode, and you select all the verts and move the object, the object center will stay in place… hence, you can control the pivot point of an object. Always remember to move an object within the environment in object mode, and adjust the center point of an object in edit mode.

Ok so I was not sure where to pick up the lil indent. Kinda like one of those cheap bomb diffuse manuals.
“Cut the Blue wire and then the Red wire, but not before you cut the Yellow wire FIRST!” Kaboom! LOL

Thanks to you help I got to here:

I have a camera question John while I have your attention. Why is it as I set my camera and want to pull back to capture my whole set, it gets tremendous shadows. I even added two emitters on the walls and this is as far as I can pull back. I had to shrink my set to fit it in the camera’s frame. I am afraid when I add my actor it is going to look to small…

For the disappearing part while in camera view, select the camera, then go to the camera panel and increase The Clipping End :

Thanks Sanctuary appreciate the screen grabs. It took me a minute to figure I needed to first hi lite Camera above to see that menu.
By cranking up that setting has no affect on anything other then bringing it into focus…? Right? Is that a Depth of Field setting?

Under Sensor size- What does that mean and how do I match it on the camera I am using? I am using a Canon M-Series 301
with a 1\3Cmos Where do I find the info to set these to match? If you know? Thanks for help

Select the camera, then the object data button in properties (looks like an old style film camera, 3rd from right), there’s camera presets for a bunch of cameras. Sensor size is the size of the imaging sensor in your camera.

Edit… you mentioned your sensor size in your last post… 1/3 of an inch. You can set metric or imperial units in the scene panel of the properties window.

Hi John,
Thanks for pointing that out. Here is my Camera type-

It’s CMOS Specs

I did not see where to switch it from Metric to Standard / Imperial.

Maybe some arrows ?? Thanks 1st time using Blender as a 3d model and adding an actor via Green Screen.

Thanks for following up Sanctuary I am still trying to figure how to set up Sensor size… Should I create a new post for that? Above is the link to my sensor but I do not know where to input it.

If you mean you do not see where is the sensor size setting for the camera, it’s there on your screenshot above :