Help me please~ Hairs not attaching to mesh :s

See attached image.

I tried searching for this but I have no clue what to search for as I am rather new to the Blender.

So the problem happens when I use Add in particle mode, and the hairs just float disconnected from the mesh.

How can I fix this?

Please help me, thank you all very much in advance. :s


that is pretty bizzare. have you tried applying scale to the mesh before adding the particle emmitor? and are you using a force field of some kind?

No scale, and no force field.

Thank you for your help though, but I decided to leave this and move on to new stuff.

Some settings that affect the parent strand can make their length shorter than what the keypoints seem to indicate, so at times they can seem to “float” above the emitter. Without seeing all your hair system settings it’s not possible to be specific about why this happens, but it can be fixed fairly easily. In Particle Mode enable the display mode that shows all the hair strand keypoints. Then select all the keypoints of the strands to be moved. If the root keypoints are not embedded in the scalp emitter, disable the “Roots” option in Particle mode so the root keypoints can also be moved. Then simply grab (G-KEY) and move the strands down to scalp level.

what does your modifier stack look like?

didn’t realize this thread was months old. Sorry.