HELP! Missing Stuff

All of sudden in the middle of a modeling session things started to disappear. First, it was a reference image then the grid, lights, and camera.

I tried alt H in case anything was hidden, then I tried the overlays to see if grid and extras were selected, and they were.

I tried to save and re-launch the project.

Is this a bug and they are truly gone or something I’m overlooking/

P.S. Is there any way to post example screenshots or attachments to this group?

Can you tell us your specs?

About screenshot, you can go alt+prntscreen button and than paste it when using a paint (Windows key + R, “mspaint”) or you can go to the window, in the top left corner and there is screenshot option, it will auto-cut the top bar - this was all about Windows, if you are an MAC or Linux than most likely the window thing would work too, otherwise not sure.

But it does seem like some kind of memory leaks or something…
by the way which Blender you using?

Sorry, 2.8 on windows 10 , I5 8Mg ram.

i did the screen capture but didn’t see attach button but i see it now.

It does seem like it’s all gone. :cry::cry::cry::cry:

For most images you can simply paste them in here along with your text. No need to attach or anything.

Are you in local mode? It will say so top right 3d viewport.
Did you accidentally turn off some Collections?

Thanks for trying

Simply select your camera icon on the right and increase the distance it can see hope this solves your problem.