Help needed with skinning...

Okay…I am new to animation in blender and am having a problem that is most frustrating. I know how to set up bones and associate the vertices that should be affected by each bone via vertex groups. My problem is that many many times, when I try to skin, I will get an extra verted in the vertex group and when I pose in pose mode, some vertices get moved that shouldn’t. Now, I know that to remove the problematic vertices from the group you have to make sure the group is active, then select the bad points, then hit “Remove.” This does indeed work, because if I deselect everything, and select the vertices of that group with “Select,” I no longer get the bad points. The trouble is that even if these points are removed from the vertex groups, they still show up when I am posing. That is, even when all the vertex group data is (seemingly) correct, posing will still result in the movement of extra vertices. Any help would be appreciated, thanks!

Check that the ‘envelopes’ toggle in both the armature editing panel AND the armature modifier (if any) for mesh are turned off.


Use the weight painting mode (CTR-TAB with mesh selected, then SH-LMB over the affected area, and the vertex group(s) names will be displayed.

Sounds like those vertices are members of more than one group.

Also, check what Aligorith said that you don’t have Envelopes enabled in the Armature modfier (which defaults to being on). If you don’t have an armature modifier, but an entry under the modifier panel that says “Armature Parent Deform” (the result of a CTR-P parent to armature) with a “Make Real” button, beside it, click on the Make Real button, to turn it into a “real” Armature modifier.