Help! Subsurface modifier is shrinking object/mesh!

using subsurface modifier is causing mesh to shrink moving pre-existing vertices from their original position, so i have had to add/insert edge loops and scale/move vertices into place manually, which eats up a lot of time.:frowning:

please tell their is an alternate subdivide plugin that maintains the original size/volume of an object or that subsurface will be getting an upgrade to fix this?

Hi

In Subsurf modifier Clik Simple Button instead of Catmull - clark …:slight_smile:

Tai

“subsurface modifier is causing mesh to shrink” - this is how this thing mathematically works in poly modeling, there is no way around.
Alternatively, there is some part of something called OpenSubdiv implemented, but i think you’ll find it limited in use and having similar deficiency - you’d have to mark your curvatures which is additional workload.

Do not use Subsurf - model with sufficient mesh density and use smooth shading? I doubt this will ease modeling though, so likely no, no alternatives and i haven’t seen anything regarding upgrades coming this way too.

The whole point of the subsurf modifier is to ‘smooth’ out the vertices; it does it by multiplying the vertices/faces/edges by a factor you stipulate in the modifier panel and then rounds them out. This causes the mesh to shrink. If you need sharp edges, then it’s normal to add supporting loops which you’re doing, but you can also use bevel modifiers and other tactics to maintain the general shape.

If you just want to subdivide the amount of vertices in your mesh, then selecting all faces in edit mode, press ‘W’ and then ‘Subdivide.’ Or use use the subsurf modifier, set the type to ‘simple,’ then ‘apply’ it.

Hey, have you tried marking sharp edges, setting edge creases, or using the edge split modifier? When I worked on a car-ish shaped time machine a while back that’s how I did it. Never finished, though, maybe I should get back to that :stuck_out_tongue: