Help with background image in volumetric lighting

Hi, I need some help. I want to add a ful 360 background image to my proyect, and I hac¡ve volumetric lightning in it. When I render, all the background is black and I can only see things that are iluminated. How do I add an image and make it visible in the render?ifpa}.blend (888 KB) I`ll leave it attached so you can help me better.


Hi sopas…
I downloaded your file.

maybe look at 2. first.

  1. No Idea what you did or you try to do. Lots of lamps no 360 degree background image… no background image at all. Lots of no named geometry when I look at the outliner.

First thing you could do is use maybe layer manager. Organize the scene. And before that name all objects that way other people understand whats going on there. Object names like “Cube.001” or “Nurbs Path” or “” or “text” or whatever do not help. And if there is somekind of background image name it “background image”. Under your world background shader is no texture… just a simple background and volume shader. And provide the file with a camera that is set to viewport. :slight_smile: hope it doesnt sound to harsh.

  1. Add a background image and name everything. You can add backgrounds under world shaders or by adding image planes. Or you create a sphere and map that 360 degree texture on it.

You have the world’s volumetric lighting enabled. You’ve essentially put an infinitely big box of “fog” in your scene. And something infinitely big will become infinitely dense, no matter how dark the volume’s color is, or how low the density is. A better way to do it would be to surround the immediate scene (I.E., only what the camera can see) with a cube and set that as the source of the volume instead of the world’s volume, like what you’ve already done. Just disable the world’s volume and set the HDRI/360 image you want.

Nice scene by the way! Very good job! :slight_smile: