Help with rig parenting (.blend attached)

Hey guys,

I’m new to Blender and finished my first sculpt, but have been hopelessly stuck on the rigging process. I want to give this four-legged friend a walking cycle animation, but no matter how many different tutorials I consult, I just fail at making the rig stick to the object. The only thing I’ve managed is to pose it via Face Sets/Pose Brush, but that only goes so far.

I’ve created the metarig from the Rigify Horse preset and it seems to generate the rig fine. I get stuck when I select the object and rig and parent with Automatic Weights - in Pose Mode the rig will just move by itself. I’ve tried scaling up the body before generating the rig and selecting everything in Edit Mode before parenting weights without any change.

I briefly tried weight painting on the metarig (which was completely blue, so nothing was applied successfully), but Blender goes extremely laggy in this mode and it doesn’t seem like the most efficient option.

I’ve uploaded the blend file here: [file removed since the issue is solved]

If you can, please do let me know what I’m doing wrong here - any help is much appreciated!

1 Like

The main problem here is that you have 3 million vertices. That’s basically unusable for armature deformation.

Your autoweights are failing due to a combination of the vertex density and the actual size of the model, in Blender units. But even if you were to weight it manually, it’s basically impossible to use an armature on a model with this many vertices anyways.

You need to create a lower poly retopo of the model and weight (and armature deform) that instead. I would recommend under 100k vertices.

In order to recreate the high poly details, you can bake a normal map from the high poly, you can bake a displacement map, or you can use your low poly to mesh deform your high poly. Those last two would be things you’d only ever enable at time of render, after doing your animation on the low poly alone.


Cheers, @bandages! I had done a retopology earlier in the process, but must’ve accidentally gotten rid of it somewhere along the way. After a new retopo and regenerating the rig, it does exactly what it’s supposed to.

Thanks a million (for pointing out the millions of vertices)!