I have 1200 frames of animation,did textures,materials etc.
I’ve put off fluid simulation for some time.
But I’m having issues doing a simulation in a small container.
If I scale the container it works however I can’t scale the whole scene since if I scale the character rig it will break it and I want to keep it’s key frames.
Any idea on how to make it interact properly the container object that only works well and accurately when it’s scaled up?
Thanks in advance,

Select the domain and go to the “Fluid” panel.
There is a group of 4 small buttons (Std, Adv, Bnd, Par) select Adv.
There is a setting called “Realworld-size” it is probably set to 0.030. (I believe it is the size in meters of 1 Blender Unit) Change it until your fluid sim works right at its normal scale.

Nope I set it to around 2 meters already,tested it at 250 res,
the box is around that realworld size.
I was able to scale the whole scene up somehow without tons of problems.
Have to do lots of non armature keying since the animation were global for them,
unlike the rigs local key frames.

Here is another problem I truly don’t have a clue what’s wrong.
When I scrub my animation it skips,
I have been able to scrub a fluidism scene much more complex than what I’m working with without an issue.
What setting could I have wrong ?