hotkeys on macbook pro

i just got my new macbook pro two weeks ago and i am having trouble finding the right hotkeys / shortcuts.
i have been on windows ever since, two months on ubuntu, so i am not too experienced with OSX. perhaps someone can help me, where i can find the following hotkeys / shortcuts on a german macbookpro-keyboard?

  1. equivalent to "Numpad / " for switching between global and local view
  2. equivalent to "Numpad . " for “View selected”
  3. equivalent to “~” for view all layers
  4. equivalent to "Numpad + " for incremental saving - the “+” near the return-key doesn’t work, while the “-” is working as expected.

and finally: there is no solution for the viewport-bugs, right? i tried davidlandwehr’s builds, but the nodes are still messed up, and, most annoying, the background image is still destorted. :frowning: but there have to be quite a lot of MBP-users, so all of you are living with those bugs? any workarounds?

I can answer number 1 and 3. Global/Local view switch is the “” key, above return. All layers is the “`” key, next to the number 1. They work on my Macbook, I can’t be sure they will work for you. The other 2, I don’t know, but would love to find out, especially number 2 which I used tons on my old windows and now cannot.

I’m working on a MacBook 13", the 2.16 version, with a Belgian keyboard.
Mine still has the numeric keypad under the fn modifier.
But I read somewhere that Apple removed that in the new models (dunno about the german keyboard though).
But that one still works for me.

Did you try in the Blender preferences panel under “System & OpenGL” the button “Emulate Keypad”?
Maybe there is a solution.

About the Leopard bugs, I thought they only appeared with the 13" MacBook videocard from Intel.
MacBook Pro’s normally shouldn’t have those problems.
Anyway, do you have the v5 from davidlandwehr?

thanks for your answer!
unfortunately it won’t work, maybe because i am using a german keyboard. well, must be one more reason to be exited about blender 2.50… :wink: