How can I create a lamp (emission shader) that doesnt cast any shadows on its surroundings


(Splitting_Atoms) #1

Hi guys, im making a custom lamp for my archviz project. Im doing this by putting an emission shader on a object. So far so good…its giving light.

But… I dont want this lamp to cast ANY shadows whatsoever. I just want it to light stuff

Is this possible? How would I set up the nodes for this?


(sozap) #2

I’m not sure it’s possible, I think only regular lamps have the option to not cast shadows.
As far as I understand, in cycles Diffuse and Shadows are kind of related (it’s the same thing) , that’s why this is complicated to do.

Maybe it would be better to cheat this in compositing ?


(CarlG) #3

Why would you want such a light for archviz? I though realism was strived for.
Anyhow, you could setup the lamp itself to be camera visible only, and fake the effect using a circular array of area lights with shadows turned off, as we don’t have light tubes/cones which would be better suited.

Don’t forget that in real film, if the practical light doesn’t cut it for lighting purposes (hardly ever), additional off screen lights are brought in to help it out. I.e. a table lamp in the background isn’t enough for proper backlighting/hairlighting, so an overhead is used off screen to mimic that the rimlight is caused by the table lamp.

Rendering cheats are fine, but it doesn’t hurt to have the tricks real photographers and filmatographers (?) have up their sleeve and utilize those for rendering instead.


(Handel) #4

Wasn’t there a rendering options “No shadows”?


#5

Try using an area lamps instead of an emission plane. Emission planes tend to be finnikier in general, as well as needing more samples. On the area lamps setting, you can check off the “cast shadows” button And, if you need fancy light patterns (the only reason I can think of using a emission plane) try using and IES texture in the new 2.79 builds.


(CarlG) #6

@Handel:
Afaik, only lamps have no shadows option, found in the lamp tab settings. Objects using emission are not lamps so the option is missing.

I fiddled around with this, and the point is it takes a while to setup to make it approximately match the nonfake version. You’ll also have to render out the nonfake version first just to keep it as a reference for tuning the fake stuff. And the fake version might be noisier because it requires more (area) lights.

Here is the real version of a table lamp on some shiny tiles:

And here is the fake version; “not in shadow area” under the lamp is deliberate to show this is something you’ll have to consider. A couple of area lamps are also glossy visible, indicating this is also something you have to consider.

Screenshot. The righmost white tab is what is creating the “not in shadow area” part. The shade itself is just math nodes describing fake lighting values and “shadows” of the bars inside - it’s just a conical mesh with nothing inside (except the base).

Btw, the selected light is an actual spot light inside the lamp so I could control the shadow from the lamp base itself. The rest of the lights, although named spot, are actually rectangular area lights in a circular array.

I would not use this for anything though.


(burnin) #7

Alternative
Two-component Light (recipe):

ShadelessLamp%20(2-components)

You need 2 objects:

  • Mesh
  • Point Lamp

Mesh using Emission shader applied is only visible to Camera & Gloss (Object Properties > Cycles Settings)
Within, there’s a Point Lamp with Shadow casting unchecked & Gloss invisible to camera (Cycles Settings).

ShadelessLamp_2component.blend (812.1 KB)

Enjoy learning.

PS. Also, shadeless shading is prepared within as an example, if such a need occurs.

Yup, used a lot in arch-viz, when it’s more important to get a pleasing (winning) image fast and less about physical accuracy. Think competitions & satisfying clients with cheap kitsch furniture… bling-bling. :wink:


(Splitting_Atoms) #8

Thank you guys so much for these replies. Really insightfull!
Im learning so much everyday with this programme. Love this community. Thanks again guys